Opened 5 months ago

Closed 5 months ago

#31629 closed task (fixed)

Remove non-_ex typedvar.c function

Reported by: nickm Owned by: nickm
Priority: Medium Milestone: Tor: 0.4.2.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: network-team-roadmap-august, asn-merge, dgoulet-merge
Cc: nickm, teor, gaba Actual Points:
Parent ID: #29211 Points: 0
Reviewer: Sponsor:

Description

This API is unused and untested: we may as well remove it entirely before it accumulates technical debt.

Child Tickets

Change History (5)

comment:1 Changed 5 months ago by nickm

I have a branch ticket31629 with a PR at https://github.com/torproject/tor/pull/1295 .

There is no changes file here, since it contains no changes beyond those already contained in earlier commits. There are two commits: one is pure code removal, and the other is automatically generated function renaming.

I'll put this in needs_review once CI passes.

comment:2 Changed 5 months ago by nickm

Status: assignedneeds_review

comment:3 in reply to:  1 Changed 5 months ago by teor

Keywords: asn-merge dgoulet-merge added
Status: needs_reviewmerge_ready

Replying to nickm:

I have a branch ticket31629 with a PR at https://github.com/torproject/tor/pull/1295 .

There is no changes file here, since it contains no changes beyond those already contained in earlier commits. There are two commits: one is pure code removal, and the other is automatically generated function renaming.

I'll put this in needs_review once CI passes.

Looks fine to me, I confirmed the second commit using the script:

$ find src -name *.c -o -name *.h | xargs /usr/bin/perl -w -i -p -e 's{typed_var_(assign|free|encode|copy|eq|ok|kvassign|kvencode|mark_fragile)_ex}{typed_var_$1}g;'
$ git diff nickm/ticket31629

CI passed, and I am also happy with the coverage:

24 of 26 (92.31%) changed or added relevant lines in 2 files are covered.

comment:4 Changed 5 months ago by teor

There might be some minor merge conflicts with these tickets, feel free to put back in needs_revision, or ask nickm how to fix the conflict.

comment:5 Changed 5 months ago by asn

Resolution: fixed
Status: merge_readyclosed

Merged!

Note: See TracTickets for help on using tickets.