#31689 closed task (duplicate)

Upgrade go to 1.13+

Reported by: JeremyRand Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-rbm
Cc: Actual Points:
Parent ID: #31688 Points:
Reviewer: Sponsor:

Description

Go should be upgraded to 1.13 or higher; this is a prerequisite to http://ea5faa5po25cf7fb.onion/projects/tor/ticket/31688 .

Child Tickets

Change History (5)

comment:1 Changed 14 months ago by JeremyRand

Are there any expected compatibility issues from upgrading to Go 1.13, or should it just be as simple as bumping the version number in the go project config? If the latter, I'm happy to code up a patch for this one.

comment:2 Changed 13 months ago by gk

Keywords: tbb-rbm added
Parent ID: #31688

comment:3 in reply to:  1 Changed 13 months ago by gk

Replying to JeremyRand:

Are there any expected compatibility issues from upgrading to Go 1.13, or should it just be as simple as bumping the version number in the go project config? If the latter, I'm happy to code up a patch for this one.

Hard to say. :) Give it a try if you want?

comment:4 Changed 12 months ago by sysrqb

Can this be closed as a duplicate of #32027? (I realize this ticket came first, but that ticket has more info).

comment:5 in reply to:  4 Changed 12 months ago by gk

Resolution: duplicate
Status: newclosed

Replying to sysrqb:

Can this be closed as a duplicate of #32027? (I realize this ticket came first, but that ticket has more info).

Sounds good.

Note: See TracTickets for help on using tickets.