Opened 5 weeks ago

Closed 3 weeks ago

Last modified 2 weeks ago

#31720 closed defect (fixed)

Address bar auto-complete is broken on Android

Reported by: sysrqb Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-mobile, ff68-esr, TorBrowserTeam201909R
Cc: Actual Points: 0.5
Parent ID: Points: 1
Reviewer: Sponsor:

Description

When text is typed into the address bar, none of the auto-complete options are shown.

Child Tickets

Change History (6)

comment:1 Changed 4 weeks ago by sysrqb

Points: 1

comment:2 Changed 4 weeks ago by sysrqb

This looks like it may be the cause:

        // Website suggestions for address bar inputs should not be enabled when running in automation.
        // After the upgrade to support library v.26 it could fail otherwise unrelated Robocop tests
        // See https://bugzilla.mozilla.org/show_bug.cgi?id=1385464#c3
        if (!isInAutomation) {
            mBrowserToolbar.setOnFilterListener(new BrowserToolbar.OnFilterListener() {
                @Override
                public void onFilter(String searchText, AutocompleteHandler handler) {
                    filterEditingMode(searchText, handler);
                }
            });
        }

comment:3 Changed 4 weeks ago by sysrqb

Building and testing bug31720_00 now.

comment:4 Changed 3 weeks ago by sysrqb

Keywords: TorBrowserTeam201909R added; TorBrowserTeam201909 removed
Status: newneeds_review

Okay, setting for review - bug31720_01.

comment:5 Changed 3 weeks ago by gk

Resolution: fixed
Status: needs_reviewclosed

Looks good, thanks. Cherry-picked onto tor-browser-68.1.0esr-9.0-2 (commit 683863bc344137462c60c6ae001d1333df41297d).

comment:6 Changed 2 weeks ago by sysrqb

Actual Points: 0.5
Note: See TracTickets for help on using tickets.