Opened 11 months ago

Closed 2 months ago

#31731 closed defect (not a bug)

Upgrade to ESR 68-based browser makes description field of bookmarks empty

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: ff68-esr, TorBrowserTeam201910, tbb-9.0-issues, tbb-regression, tbb-9.0.1-can
Cc: intrigeri Actual Points:
Parent ID: Points: 0.25
Reviewer: Sponsor:

Description

As reported on our blog (https://blog.torproject.org/comment/283838#comment-283838), starting with ESR 68 the description fields in bookmarks are empty. Switching back to 8.5.5 (hence ESR 60) solves that.

Child Tickets

Change History (7)

comment:1 Changed 11 months ago by gk

Points: 0.50.25

Hrm. It seems that field basically got removed: https://www.mozilla.org/en-US/firefox/62.0/releasenotes/ (thanks cypherpunk for the link). I wonder whether there is more to it for us to do here.

Last edited 11 months ago by gk (previous) (diff)

comment:2 Changed 11 months ago by pili

Keywords: TorBrowserTeam201910 added

comment:3 Changed 11 months ago by pili

Keywords: TorBrowserTeam201909 removed

comment:4 Changed 10 months ago by intrigeri

Cc: intrigeri added

comment:5 Changed 10 months ago by gk

Keywords: tbb-9.0-issues tbb-regression tbb-9.0.1-can added

comment:6 Changed 10 months ago by gk

Reading I wonder whether there is still something we can do here:

Removed the description field for bookmarks. Users who have stored descriptions using the field may wish to export these descriptions as html or json files, as they will be removed in a future release.

comment:7 in reply to:  6 Changed 2 months ago by sysrqb

Resolution: not a bug
Status: newclosed

Replying to gk:

Reading I wonder whether there is still something we can do here:

Removed the description field for bookmarks. Users who have stored descriptions using the field may wish to export these descriptions as html or json files, as they will be removed in a future release.

Maybe user-facing changes like this should be included within the Tor Browser release notes when migrating between (ESR) versions.

But, for this case, I don't think we should re-add/re-implement this functionality, so I'll close it as not-a-bug.

Note: See TracTickets for help on using tickets.