Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#31738 closed defect (not a bug)

issue with tor 8.5.4

Reported by: torqq Owned by:
Priority: Immediate Milestone:
Component: Community/Tor Support Version:
Severity: Critical Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Following files in folder TorBrowser/PluggableTransports/twisted/python/test

fakepwd.py
fakeendpoint.py

see attached

Child Tickets

Attachments (4)

test_fakepwd.py (13.8 KB) - added by torqq 4 months ago.
fakeendpoint.py (1.4 KB) - added by torqq 4 months ago.
test_fakepwd.2.py (13.8 KB) - added by torqq 4 months ago.
fakepwd.py (5.9 KB) - added by torqq 4 months ago.

Download all attachments as: .zip

Change History (7)

Changed 4 months ago by torqq

Attachment: test_fakepwd.py added

Changed 4 months ago by torqq

Attachment: fakeendpoint.py added

Changed 4 months ago by torqq

Attachment: test_fakepwd.2.py added

Changed 4 months ago by torqq

Attachment: fakepwd.py added

comment:1 Changed 4 months ago by ggus

Resolution: not a bug
Status: newclosed

Hi, these files are used by Pluggable Transports.

If you're concerned that you have downloaded a compromised Tor Browser, we recommend you to download again and verify the files: https://support.torproject.org/tbb/how-to-verify-signature/

comment:2 Changed 4 months ago by ggus

Component: - Select a componentCommunity/Tor Support

comment:3 Changed 4 months ago by gk

Just to add here what ggus said: those files are part of the Twisted library that the old obfsproxy pluggable transport uses (used). The 8.5 series is the last one that contains those, thus the files you are concerned about will be gone with Tor Browser 9.

Note: See TracTickets for help on using tickets.