Opened 4 weeks ago

Closed 13 days ago

#31763 closed defect (duplicate)

relay-search lists flakey as down for an hour or two, when it's never been reachable

Reported by: arma Owned by: metrics-team
Priority: Low Milestone:
Component: Metrics/Relay Search Version:
Severity: Normal Keywords:
Cc: cohosh, phw Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

https://metrics.torproject.org/rs.html#details/5481936581E23D2D178105D44DB6915AB06BFB7F
is marked as offline, and the "downtime" section varies over time but it always seems to be more than one hour and less than two hours.

That's because the bridge firewalled its ORPort, so it never gets the Running flag from Serge, so bridgedb won't give it out. Makes sense -- it is the snowflake bridge, so it receives its connections via the bridge-side snowflake proxy, not direct to the ORPort.

But metrics seems to have hit an edge case: it does something weird when it has no known "time it was last up" value.

(Not a big deal, but it's been sitting in a tab for some days now and I figured I should file the ticket.)

Child Tickets

Change History (2)

comment:1 Changed 4 weeks ago by cohosh

Cc: cohosh phw added

comment:2 Changed 13 days ago by karsten

Resolution: duplicate
Status: newclosed

Thanks for reporting this. It's a known issue tracked under #11430. Maybe it's time to fix this now. Closing this one as duplicate after pasting the description to that other ticket.

Note: See TracTickets for help on using tickets.