Opened 5 weeks ago

Closed 3 weeks ago

#31796 closed defect (worksforme)

practracker git hook warning: Unusual pattern permitted.h in testdata

Reported by: teor Owned by: nickm
Priority: Medium Milestone: Tor: 0.4.2.x-final
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Normal Keywords: 042-should, 042-regression
Cc: Actual Points:
Parent ID: Points: 0.1
Reviewer: Sponsor: Sponsor31-can

Description

When I go to commit code, I see:

Unusual pattern permitted.h in /Users/hyper/dev/tor/scripts/maint/practracker/testdata

I think this warning is new, but it doesn't seem right.

Child Tickets

Change History (2)

comment:1 Changed 3 weeks ago by nickm

Status: assignedneeds_information

I am having a hard time reproducing this. Does it still happen for you? I think that both the includes.py and practracker.py entrypoints now only search under "src" by default.

If this is still happening, can you verify:

  1. which of the two entrypoints (practracker.py or includes.py) causes this warning.
  1. the actual command line and environment that are passed to that entry point.
  1. The exact version of the git hook that you're using
  1. the directory that you are committing from in relation to the git checkout.

Thanks for your help!

comment:2 Changed 3 weeks ago by teor

Resolution: worksforme
Status: needs_informationclosed

I can't reproduce this issue any more, I think we fixed it in some other ticket.

Note: See TracTickets for help on using tickets.