#31879 closed defect (not a bug)

tor browser won't start

Reported by: robrenard Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor unexpectedly exited error. There is no log information. Have re-installed Tor and still get the same error See attached screen shots for system info and error.

Child Tickets

Attachments (2)

TOR_snapshot1on 2019-09-26.png (106.3 KB) - added by robrenard 11 months ago.
System Info from 2019-09-26 22-20-08.png (46.7 KB) - added by robrenard 11 months ago.

Download all attachments as: .zip

Change History (10)

Changed 11 months ago by robrenard

Changed 11 months ago by robrenard

comment:1 Changed 11 months ago by arma

Component: Core Tor/TorApplications/Tor Browser
Owner: set to tbb-team

(Linux mint, not Windows, so it's probably not #10416)

comment:2 Changed 11 months ago by cypherpunks

But it's tor exited, not Tor Browser ;)

comment:3 Changed 11 months ago by gk

What happens if you start Tor Browser in a terminal in your tor-browser_en-US folder (assuming your are using the English version) with ./start-tor-browser.desktop --debug? What output do you get?

comment:4 Changed 11 months ago by robrenard

Ran this script and got the same result as in the screen shots. Debug is as follows:

sh -c '/tor-browser_en-US/Browser/start-tor-browser --debug

Unable to update the static FcBlanks: 0x0600
Unable to update the static FcBlanks: 0x0601
Unable to update the static FcBlanks: 0x0602
Unable to update the static FcBlanks: 0x0603
Unable to update the static FcBlanks: 0x06dd
Unable to update the static FcBlanks: 0x070f
Unable to update the static FcBlanks: 0x2028
Unable to update the static FcBlanks: 0x2029
Unable to update the static FcBlanks: 0xfff9
Unable to update the static FcBlanks: 0xfffa
Unable to update the static FcBlanks: 0xfffb
Sep 27 23:50:56.011 [notice] Tor 0.3.5.8 (git-5030edfb534245ed) running on Linux with Libevent 2.1.8-stable, OpenSSL 1.0.2q, Zlib 1.2.8, Liblzma N/A, and Libzstd N/A.
Sep 27 23:50:56.012 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Sep 27 23:50:56.012 [notice] Read configuration file "/home/robrenard/tor-browser_en-US/Browser/TorBrowser/Data/Tor/torrc-defaults".
Sep 27 23:50:56.012 [notice] Read configuration file "/home/robrenard/tor-browser_en-US/Browser/TorBrowser/Data/Tor/torrc".
Sep 27 23:50:56.022 [notice] Opening Socks listener on 127.0.0.1:9050
Sep 27 23:50:56.022 [warn] Could not bind to 127.0.0.1:9050: Address already in use. Is Tor already running?
Sep 27 23:50:56.022 [notice] Opening Control listener on 127.0.0.1:9151
Sep 27 23:50:56.023 [notice] Opened Control listener on 127.0.0.1:9151
Sep 27 23:50:56.023 [notice] Closing partially-constructed Control listener on 127.0.0.1:9151
Sep 27 23:50:56.023 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.
Sep 27 23:50:56.023 [err] Reading config failed--see warnings above.

comment:5 Changed 11 months ago by gk

Where did you get your Tor Browser from? We ship it to use 127.0.0.1:9150 as address for the Socks listener to explicitly not interfere with a Tor installed system-wide (which is listening on 9050) which seems to happen in your case.

What Tor Browser version is that? What happens if you download and use the latest version from our website?

comment:6 Changed 11 months ago by robrenard

here's my latest download tor-browser-linux64-8.0.7_en-US.tar.xz. Prior to this one I have had another version running but then one day it wouldn't work any more, so I downloaded this one. I believe I got it through a search and went to the Tor site to download it. But can't swear to that. Will download ffrom your website https://www.torproject.org/download/. I'll let you know what happens.
Thanks

comment:7 Changed 11 months ago by robrenard

Well "heavens to Betsy" downloaded 8.5.5 and it seems to be working fine. I recall now that I downloaded it from Package Manager, but it did say it would install latest version. Guess not huh? :). btw it is using port 9150 now.

Lesson learned

Thanks again

comment:8 Changed 11 months ago by gk

Resolution: not a bug
Status: newclosed

Glad this is working for you!

Note: See TracTickets for help on using tickets.