Opened 7 weeks ago

Closed 6 weeks ago

Last modified 12 days ago

#31886 closed defect (fixed)

ko bundles are broken - XML Parsing Error

Reported by: Thorin Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-regression, TorBrowserTeam201910
Cc: emmapeel Actual Points: 0.25
Parent ID: Points: 0.5
Reviewer: Sponsor:

Description

I updated ko v9.0a1 (ESR60) to v9.0a6 (ESR68) and got the following error.

XML Parsing Error: error in processing external entity reference
Location: chrome://browser/content/browser.xul
Line Number 55, Column 1:

%aboutTorDTD;
^

Updating: the browser window is loaded (sans chrome, all white), and after the tor connection is successful, it then puts this error message into the browser window.

So I tried a new install, to see what happens. Looking around, I noticed that the Back button is not translated.

And the same error occurs as the update, but instead of using the browser window (which is not loaded), it flashes a dialog for about 0.1468 seconds.

Pics to follow

Child Tickets

Attachments (3)

ko-update.png (13.0 KB) - added by Thorin 7 weeks ago.
ko-newinstall.png (175.2 KB) - added by Thorin 7 weeks ago.
the vanishing dialog
ko-back.png (39.4 KB) - added by Thorin 7 weeks ago.
back button is not translated

Download all attachments as: .zip

Change History (13)

Changed 7 weeks ago by Thorin

Attachment: ko-update.png added

Changed 7 weeks ago by Thorin

Attachment: ko-newinstall.png added

the vanishing dialog

Changed 7 weeks ago by Thorin

Attachment: ko-back.png added

back button is not translated

comment:1 Changed 7 weeks ago by gk

Keywords: tbb-9.0-must-alpha TorBrowserTeam201909 added
Points: 0.5

Visible on a Linux box, too.

Last edited 7 weeks ago by gk (previous) (diff)

comment:2 Changed 7 weeks ago by gk

Cc: emmapeel added
Keywords: tbb-9.0-must-alpha removed
Priority: MediumHigh
Summary: ko 9.0a6 (Windows 64bit) update/new-install - XML Pasing Errorko bundles are broken - XML Pasing Error

Actually our stable bundles are affected as well. We bricked them (too) with a translations update for Torbutton 2.1.13:

-<!ENTITY aboutTor.donationBanner.buttonA "Donate Now">
+<!ENTITY aboutTor.donationBanner.line2e "Tor 를 강하게^] 유지하기.">

The XML parser is choking at "^" or "]" or both (I have not tested). This seems to be a mistake in the translation.

emmapeel: can you fix that on the translations side so we can update new strings for Torbutton?

Last edited 6 weeks ago by arma (previous) (diff)

comment:3 Changed 7 weeks ago by gk

Keywords: tbb-regression added

comment:4 Changed 7 weeks ago by Thorin

my fault: title has a typo: Parsing

comment:5 Changed 6 weeks ago by gk

I pushed commit 0e2b3bc5f11181fbd7d42524f2591149688e210d to torbutton's master branch which should fix that. I'll verify on tomorrow's nightly builds.

comment:6 Changed 6 weeks ago by pili

Summary: ko bundles are broken - XML Pasing Errorko bundles are broken - XML Parsing Error

comment:7 Changed 6 weeks ago by pili

Keywords: TorBrowserTeam201910 added

comment:8 Changed 6 weeks ago by pili

Keywords: TorBrowserTeam201909 removed

comment:9 Changed 6 weeks ago by gk

Actual Points: 0.25
Keywords: tbb-backport added
Resolution: fixed
Status: newclosed

We are good here. We could think about backporting this patch in case we do another stable release.

comment:10 Changed 12 days ago by gk

Keywords: tbb-backport removed

No esr60-based builds anymore and thus no backport.

Note: See TracTickets for help on using tickets.