Opened 6 weeks ago

Closed 6 weeks ago

Last modified 5 weeks ago

#31935 closed defect (fixed)

TB9.0a7 is asking for a new profile

Reported by: antonela Owned by: mcs
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: TorBrowserTeam201910R, tbb-9.0-must
Cc: mcs, brade, tbb-team Actual Points: 0.25
Parent ID: Points: 0.5
Reviewer: Sponsor:

Description

After installing the new alpha in MacOS Mojave v10.14, a New Profile box was prompted. Screenshot attached.

Child Tickets

Attachments (1)

index.png (163.6 KB) - added by antonela 6 weeks ago.

Download all attachments as: .zip

Change History (11)

Changed 6 weeks ago by antonela

Attachment: index.png added

comment:1 Changed 6 weeks ago by gk

Keywords: TorBrowserTeam201910 tbb-9.0-must added
Points: 0.5
Priority: MediumHigh
Status: newneeds_information

Where did you put your browser? Into /Applications? And that's not been caused by an update but a new installation?

comment:2 Changed 6 weeks ago by antonela

No. I installed it from the /download folder, and yes, it went to /Applications. When I opened it, the popup got prompted.

No update, fresh install.

comment:3 Changed 6 weeks ago by gk

Do you know which version was installed previously in /Applications?

comment:4 Changed 6 weeks ago by antonela

8.5
8.5.4
9.0a3
9.0a4
9.0a6
9.0a7
a few tbb-nightly

:/

Let me try again in a fresh environment, and back to this ticket.

comment:5 Changed 6 weeks ago by gk

No worries. I was interested in the one immediately before you put the new version over it as I was trying to reproduce your error.

comment:6 Changed 6 weeks ago by antonela

good question! It was a custom nighly made by pospeselr for me, probably without the patch that fixes that problem.

comment:7 Changed 6 weeks ago by mcs

Cc: tbb-team added
Owner: changed from tbb-team to mcs
Status: needs_informationassigned

Kathy and I saw this same prompt while working on #31607; we were reusing various TorBrowser-Data directories in an attempt to better understand the causes for that bug. I had it on my TODO list to file a ticket but now Antonela did it for me :)

Since Tor Browser does not support more than one profile, we should disable this prompt and related code. We can do that by changing a MOZ_BLOCK_PROFILE_DOWNGRADE configure option from True to False. This is similar to what we did for #31457 and in fact the options are right next to each other in browser/moz.configure.

comment:8 Changed 6 weeks ago by mcs

Keywords: TorBrowserTeam201910R added; TorBrowserTeam201910 removed
Status: assignedneeds_review

comment:9 Changed 6 weeks ago by gk

Resolution: fixed
Status: needs_reviewclosed

Looks good. Merged to tor-browser-68.1.0esr-9.0-2 (commit d375c811357fc32f7f0d2e399ebb9edb2764eb76).

comment:10 Changed 5 weeks ago by mcs

Actual Points: 0.25
Note: See TracTickets for help on using tickets.