Opened 8 years ago

Closed 7 years ago

#3195 closed defect (fixed)

Vidalia in TBB gives no hint that there's a browser window coming

Reported by: arma Owned by: chiiph
Priority: High Milestone: Vidalia: 0.3.x
Component: Archived/Vidalia Version:
Severity: Keywords: arma-cares
Cc: erinn, mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In TBB, Vidalia will launch a browser once Tor is done bootstrapping. But while Tor is bootstrapping, the user has no hint that there might be a browser later.

One option would be for Vidalia to try to say that somewhere in its control panel interface.

Another option would be to launch the browser immediately (though perhaps after #3077 is done), and have it go to some local html page that explains what's going on, and then have Torbutton or something refresh the page once Tor tells Vidalia that Tor is ready. (If we go with this option, maybe this ticket shouldn't be in the Vidalia category.)

Child Tickets

Change History (10)

comment:1 Changed 8 years ago by arma

Cc: erinn mikeperry added

comment:2 Changed 8 years ago by mikeperry

I think the solution here is for Vidalia to inform the user. The problem is not just that the Tor startup phase is very slow, but that our Firefox can also take a long time to even launch on some platforms.

Also, it probably will confuse people to get a browser that won't work until vidalia is done bootstrapping.

comment:3 Changed 8 years ago by arma

I wonder if we can make use of the status bar for this. When it gets to 100% it says 'Tor is running' now. Perhaps it should say 'Launching separate Firefox' while it's doing that?

I bet we could improve the interface part past that too. I could imagine a column of names, each with their own bootstrap bar -- Tor, Polipo (if used), Firefox, etc. Then it's clearer at a glance that there's something more coming.

(I want to avoid trying to figure out the perfect sentence, and then figure out where on Vidalia's interface to paste the sentence. Nobody will know to look for it in the first place.)

comment:4 Changed 8 years ago by chiiph

Milestone: Vidalia-0.3.X

I'd like to see this in the next alpha release, but more as a popup dialog with a clock-like icon or something that says: "Please wait until the new Firefox opens...".

I think it'd be nice if we could change TBB's Firefox to have a green onion icon, so that people can actually differentiate which Firefox is the TBB one, so may be we can say "Please wait for the Firefox with the green onion icon".

comment:5 Changed 8 years ago by arma

What if we have Vidalia listen for the stream event from Firefox's check.torproject.org attempt, and incorporate that into the progress bar? (Perhaps in addition to some other gui suggestions here)

comment:6 Changed 8 years ago by chiiph

I don't understand what kind of feedback will the user get if we listen to those events. I mean, wouldn't it be the same as looking at the status displayed by Firefox?

Does anybody thinks that the popup dialog with a clock-like animation I talked about is a bad idea? Because I think right now it's the most straight forward way of doing this (since Vidalia doesn't know anything regarding TBB in its C++ code, it's all in a plugin).
If having a global progress bar displaying N serial progresses is a really good idea in terms of usability, I can add a way of plugin-inify that. But I also think that the user will notice this particular case more if it's separated from the "starting tor"-progressbar that they already know and won't pay much attention to.

comment:7 Changed 8 years ago by arma

Priority: normalmajor

comment:8 in reply to:  6 Changed 8 years ago by arma

Replying to chiiph:

I don't understand what kind of feedback will the user get if we listen to those events. I mean, wouldn't it be the same as looking at the status displayed by Firefox?

The goal would be that Vidalia watches for the events, and it knows to not let the user think everything has started up until it sees activity from Firefox.

Does anybody thinks that the popup dialog with a clock-like animation I talked about is a bad idea? Because I think right now it's the most straight forward way of doing this (since Vidalia doesn't know anything regarding TBB in its C++ code, it's all in a plugin).
If having a global progress bar displaying N serial progresses is a really good idea in terms of usability, I can add a way of plugin-inify that. But I also think that the user will notice this particular case more if it's separated from the "starting tor"-progressbar that they already know and won't pay much attention to.

I'm not sure which approach would be more usable. I'd say build whichever one you are happier building, and we'll try it out, get user feedback, and proceed from there.

comment:9 Changed 8 years ago by arma

Keywords: arma-cares added

Adding the arma-cares keyword, since this is something that I deeply want to see done, and maybe it's not moving forward because nobody thinks anybody cares. :)

comment:10 Changed 7 years ago by chiiph

Resolution: fixed
Status: newclosed

The still-unreleased-but-soon 0.3.1 will come with the tbb plugin, which notifies the user through tray message. Since most of you will wait until the TBB release of that is out to test this, I'm going to call this "fixed" until someone reopens with a complain.

Note: See TracTickets for help on using tickets.