Opened 8 months ago

Closed 3 months ago

Last modified 3 months ago

#31984 closed defect (not a bug)

TB 9.x partial update: unable to remove directory: tobedeleted

Reported by: mcs Owned by: brade
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-9.0, tbb-update, TorBrowserTeam202002
Cc: tbb-team Actual Points: 0.25
Parent ID: Points: 1.0
Reviewer: Sponsor:

Description

On October 02, 2019 an anonymous blog commenter reported something that appears to be an update problem. From https://blog.torproject.org/comment/284256#comment-284256:

Anonymous (not verified) said:
partial update is not clean; logs:
NS_main: unable to remove directory: tobedeleted, err: 41

boklm said:
Where/when do you have this error?

Anonymous (not verified) said:
Win 10 x64

Child Tickets

Change History (11)

comment:1 Changed 8 months ago by mcs

brade and I will need to double-check, but if I remember correctly the updater log message about not being able to remove the tobedeleted directory is nothing to worry about. That directory will be removed later (when the browser is restarted).

comment:2 Changed 8 months ago by gk

Keywords: tbb-9.0 added

comment:3 Changed 7 months ago by pili

Keywords: TorBrowserTeam201911 added; TorBrowserTeam201910 removed

Moving tickets to November 2019

comment:4 Changed 6 months ago by pili

Owner: changed from tbb-team to brade
Status: newassigned

Assigning tickets to brade and mcs

comment:5 Changed 6 months ago by brade

Cc: tbb-team added

comment:6 Changed 6 months ago by pili

Keywords: TorBrowserTeam201912 added; TorBrowserTeam201911 removed

Moving tickets to December

comment:7 Changed 5 months ago by sysrqb

Keywords: TorBrowserTeam202001 added; TorBrowserTeam201912 removed

comment:8 Changed 4 months ago by pili

Keywords: TorBrowserTeam202002 added; TorBrowserTeam202001 removed

Moving tickets to February

comment:9 Changed 3 months ago by mcs

Resolution: not a bug
Status: assignedclosed

Unless the original blog commenter experienced a failed incremental update, this is not a bug. My guess is that they saw a line in their update log file that appeared to be an error and wanted to let us know about it.

Kathy and I confirmed that the log message occurs in the normal course of things. What happens is that, on Windows, updater.exe cannot delete the DLLs that it depends on. The files are renamed and moved to a temporary directory named tobedeleted. In Firefox, MoveFileEx() is used to tell the OS remove that directory upon next reboot. Since that mechanism will write to the Windows Registry (which we want to avoid), our Tor Browser patches for #4234 add an #ifdef to omit the block of code that uses MoveFileEx(), here:
https://gitweb.torproject.org/tor-browser.git/tree/toolkit/mozapps/update/updater/updater.cpp?h=tor-browser-68.3.0esr-9.5-1-build1#n4007

To make sure tobedeleted and its contents are eventually removed in Tor Browser, we added code to do so during browser start up, here:
https://gitweb.torproject.org/tor-browser.git/tree/toolkit/xre/nsUpdateDriver.cpp?h=tor-browser-68.3.0esr-9.5-1-build1#n879

comment:10 Changed 3 months ago by mcs

Actual Points: 0.25

comment:11 Changed 3 months ago by cypherpunks

Your hack seems to be a little bit dirty ;) But it is a good item for upstreaming to make updater.exe portable again :)

Note: See TracTickets for help on using tickets.