Opened 3 months ago

Closed 3 months ago

#32010 closed enhancement (not a bug)

Support querying bridge client country statistics

Reported by: womble Owned by: atagar
Priority: Medium Milestone:
Component: Archived/Stem Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The control port supports retrieving the set of countries seen over the last 24 hours using GETINFO status/clients-seen. It would be useful if this information was exposed in stem, for example in implementing this feature request in the Tor exporter: https://github.com/atx/prometheus-tor_exporter/issues/11.

Child Tickets

Change History (1)

comment:1 Changed 3 months ago by atagar

Resolution: not a bug
Status: newclosed

Hi womble. All GETINFO commands are available via the get_info() method...

my_controller.get_info('status/clients-seen')

Feel free to reopen if you have any other questions.

Note: See TracTickets for help on using tickets.