Opened 6 weeks ago

Closed 5 days ago

Last modified 5 days ago

#32019 closed defect (fixed)

TB9: Address bar and hotkey broken

Reported by: rustybird Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: ff68-esr, AffectsTails, tbb-9.0-issues, tbb-regression, tbb-9.0.1-can, GeorgKoppen201911, TorBrowserTeam201911
Cc: intrigeri, segfault Actual Points: 0.1
Parent ID: Points: 1
Reviewer: Sponsor:

Description

  1. Extract a fresh TB9 (I tested it with 9.0a7 and the 2019-10-08 nightly on Fedora Linux 30).
  1. Before the first start, set about:blank as the homepage:
    export TOR_DEFAULT_HOMEPAGE=about:blank
    
    # alternatively:
    echo 'user_pref("browser.startup.homepage", "about:blank");' >>Browser/TorBrowser/Data/Browser/profile.default/prefs.js
    
  1. Run ./start-tor-browser.desktop, connect to Tor, and wait until the main browser window opens.

After typing an URL into the address bar, it cannot be confirmed with Enter. (And autocomplete doesn't work either, e.g. "blog" is not completed to "blog.torproject.org/".) This seems to only affect the first start of a fresh TB9 installation.

If Ctrl+Shift+u (the hotkey for New Identity) is pressed while the address bar has focus, an underlined u is typed in. This problem remains even after a restart.

In contrast to #27427, the bug appears unrelated to NoScript - deleting the NoScript .xpi makes no difference. Workaround: data:, instead of about:blank as the homepage URL.

Child Tickets

Change History (18)

comment:1 Changed 6 weeks ago by gk

Cc: intrigeri segfault added; tbb-team removed

intrigeri, segfault: I wonder whether that's one of your Tails bugs (where the URL bar is not responsive).

comment:2 Changed 6 weeks ago by rustybird

Interesting that you bring up Tails: IIRC they don't set about:blank, but they do use a setup that's more or less equivalent to TOR_SKIP_LAUNCH=1 - which for me (though I haven't tried it in complete isolation yet) seems to occasionally trigger the bug even with about:tor as the homepage.

comment:3 Changed 6 weeks ago by intrigeri

Keywords: AffectsTails added

Indeed, we don't set the homepage to about:blank. But the symptoms look very much the same as what's been reported here.

Our CI is currently testing a workaround that anonym found: setting browser.urlbar.quantumbar to false.

The corresponding Tails ticket is https://redmine.tails.boum.org/code/issues/17121.

comment:4 Changed 6 weeks ago by gk

Keywords: TorBrowserTeam201910 GeorgKoppen201910 added
Points: 1

comment:5 Changed 6 weeks ago by rustybird

Setting data:, as the homepage just now happened to still trigger the bug, so it really doesn't look like it's about:blank specific - just more likely in that case. (I don't think I'm allowed to edit the ticket title)

browser.urlbar.quantumbar=false has been working good so far.

comment:6 in reply to:  5 ; Changed 6 weeks ago by gk

Summary: TB9: Address bar and hotkey broken if homepage is about:blankTB9: Address bar and hotkey broken

Replying to rustybird:

Setting data:, as the homepage just now happened to still trigger the bug, so it really doesn't look like it's about:blank specific - just more likely in that case. (I don't think I'm allowed to edit the ticket title)

browser.urlbar.quantumbar=false has been working good so far.

Does this bug happen reliably for you? Or am I right in my assumption that it is happening sometimes/often but that we don't have steps to repro it 100%?

comment:7 in reply to:  6 Changed 6 weeks ago by intrigeri

Replying to gk:

Does this bug happen reliably for you? Or am I right in my assumption that it is happening sometimes/often but that we don't have steps to repro it 100%?

FWIW, in Tails' context it happens very reliably on slower systems, and very rarely (or never at all) on faster ones. Sounds like a race condition to me.

comment:8 in reply to:  6 Changed 6 weeks ago by rustybird

Replying to gk:

Does this bug happen reliably for you?

With about:tor, data:, or a file:// homepage (the latter is the default on Whonix Workstation), it only happens sometimes. TOR_SKIP_LAUNCH=1 seems to increase the chance. OTOH about:blank has triggered it 100% of the times I went through the steps in the ticket description.

Replying to intrigeri:

FWIW, in Tails' context it happens very reliably on slower systems, and very rarely (or never at all) on faster ones. Sounds like a race condition to me.

Yeah, my system is also rather slow...

comment:9 Changed 5 weeks ago by gk

Keywords: tbb-9.0-issues tbb-regression tbb-9.0.1-can added

comment:10 Changed 4 weeks ago by gk

FWIW and to give an update: I've a machine where I can reproduce the problem. Surprisingly, I have still trouble convincing the installed Firefox to show the bug. So, I am in the process of kind of bisecting the problem on our side first to have better steps to repro (as I assume this is actually a Firefox bug).

Last edited 4 weeks ago by gk (previous) (diff)

comment:11 Changed 4 weeks ago by gk

Status: newneeds_information

rustybird: Could you try the latest alpha and see whether you can reproduce the bug? I can see the problem in 9.0a7 but not in 9.0a8 (and thus 9.0) anymore.

comment:12 in reply to:  11 ; Changed 4 weeks ago by rustybird

Replying to gk:

Could you try the latest alpha and see whether you can reproduce the bug? I can see the problem in 9.0a7 but not in 9.0a8 (and thus 9.0) anymore.

Indeed, I tried 9.0-build2 [edit: and 9.0a8] with and without TOR_DEFAULT_HOMEPAGE=about:blank and/or TOR_SKIP_LAUNCH=1 a couple of times and the main bug seems to be gone. Hurray?

One thing that might be relevant somehow: The minor secondary aspect of this ticket - If Ctrl+Shift+u (the hotkey for New Identity) is pressed while the address bar has focus, an underlined u is typed in. - now reliably occurs every time in every configuration here. I don't remember that being the case for 9.0a7, but maybe my memory is wrong. (Is there an archive where old alpha versions can still be downloaded? I don't have a copy of 9.0a7 anymore.)

Last edited 4 weeks ago by rustybird (previous) (diff)

comment:13 in reply to:  12 ; Changed 4 weeks ago by gk

Replying to rustybird:

Replying to gk:

Could you try the latest alpha and see whether you can reproduce the bug? I can see the problem in 9.0a7 but not in 9.0a8 (and thus 9.0) anymore.

Indeed, I tried 9.0-build2 with and without TOR_DEFAULT_HOMEPAGE=about:blank and/or TOR_SKIP_LAUNCH=1 a couple of times and the main bug seems to be gone. Hurray?

One thing that might be relevant somehow: The minor secondary aspect of this ticket - If Ctrl+Shift+u (the hotkey for New Identity) is pressed while the address bar has focus, an underlined u is typed in. - now reliably occurs every time in every configuration here. I don't remember that being the case for 9.0a7, but maybe my memory is wrong. (Is there an archive where old alpha versions can still be downloaded? I don't have a copy of 9.0a7 anymore.)

Good to hear. The archive is here: https://archive.torproject.org/tor-package-archive/torbrowser/.

I'll keep this ticket open to track down what actually fixed the problem...

comment:14 in reply to:  13 Changed 4 weeks ago by rustybird

Replying to gk:

The archive is here: https://archive.torproject.org/[...]

lol, I should have guessed that... thanks. Turns out the Ctrl+Shift+U = u behavior was already present in 9.0a7 in all configurations, so it's independent: #32189

comment:15 Changed 3 weeks ago by gk

Keywords: GeorgKoppen201911 added; GeorgKoppen201910 removed

Moving my tickets.

comment:16 Changed 3 weeks ago by pili

Keywords: TorBrowserTeam201911 added; TorBrowserTeam201910 removed

Moving tickets to November 2019

comment:17 Changed 5 days ago by gk

Resolution: fixed
Status: needs_informationclosed

I've no time to investigate this. :( Thus, closing seems to be the "right" thing to do. If someone wants to dig a bit to understand what fixed the issue that would be appreciated.

comment:18 Changed 5 days ago by gk

Actual Points: 0.1
Note: See TracTickets for help on using tickets.