Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#32028 closed task (duplicate)

remove obsolete media.audio_data.enabled

Reported by: Thorin Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: ff-68esr
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The pref media.audio_data.enabled can be removed from the default profile prefs, it was deprecated / removed in FF43

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1206091

Child Tickets

Change History (7)

comment:1 Changed 3 months ago by Thorin

Additionally, remove (or update the value in hardwareConcurrency)) for redundant prefs due to RFP (or keep them as defense in depth if someone disabled RFP). The RFP patches for these override the pref values - all tested in alpha 9.0a.7

comment:2 Changed 3 months ago by Thorin

...aaaand

PS: feel free to re-title the ticket to e.g. default prefs cleanup or something

Last edited 3 months ago by Thorin (previous) (diff)

comment:3 in reply to:  2 ; Changed 3 months ago by gk

Replying to Thorin:

...aaaand

Please do. I have made a collection of prefs while looking at all the closed bugs. So far I have roughly the same list as you. :)

PS: feel free to re-title the ticket to e.g. default prefs cleanup or something

There is a separate ticket for prefs clean-up #27268 which we started for ESR 60. Should we go over there adding your stuff for ESR 68?

Feel free to do so and close this ticket as a duplicate.

comment:4 in reply to:  3 ; Changed 3 months ago by Thorin

Replying to gk:

There is a separate ticket for prefs clean-up #27268 which we started for ESR 60. Should we go over there adding your stuff for ESR 68?

OK, I'll add it all in there, but this would have been a cleaner, new ticket. Just finished a buttload of checkin' and yak shaving and will post in #27268

Feel free to do so and close this ticket as a duplicate.

You'll have to close it for me. I can't edit tickets: can't change titles, keywords, status etc: I see no mechanism/menus/widgets etc to do so.

comment:5 in reply to:  4 ; Changed 3 months ago by arma

Replying to Thorin:

You'll have to close it for me. I can't edit tickets: can't change titles, keywords, status etc: I see no mechanism/menus/widgets etc to do so.

I just fixed that so you should be able to do all sorts of things now. Thanks for helping! :)

comment:6 Changed 3 months ago by Thorin

Resolution: duplicate
Status: newclosed

Duplicate of #27268

comment:7 in reply to:  5 Changed 3 months ago by Thorin

Replying to arma:

I just fixed that so you should be able to do all sorts of things now. Thanks for helping! :)

Thanks :)

Note: See TracTickets for help on using tickets.