Opened 5 weeks ago

Closed 5 weeks ago

Last modified 4 weeks ago

#32037 closed defect (wontfix)

Tor Browser 8.5.5 Encounters Javascript problem when attempting to use Meek-Azure bridges

Reported by: bakertaylor28 Owned by:
Priority: High Milestone:
Component: Circumvention/meek Version: Tor: 0.4.1.5
Severity: Major Keywords: meek, meek-azure, bridge, javascript, jar
Cc: dcf, gk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by dcf)

I'm getting the following error when trying to use meek-azure in the logs. This looks to be a javascript problem of some sort or another that needs fixing.

[WARN] Managed proxy at 'TorBrowser\Tor\PluggableTransports\terminateprocess-buffer.exe' reported: JavaScript error: jar:file:///C:/Scrubbed Path to Tor Installation Directory/Browser/TorBrowser/Data/Browser/profile.meek-http-helper/extensions/meek-http-helper@bamsoftware.com.xpi!/components/main.js, line 431: TypeError: invalid 'instanceof' operand Components.interfaces.nsIXPCException

Child Tickets

Change History (7)

comment:1 Changed 5 weeks ago by bakertaylor28

Note that I Have not been able to replicate this on other machines and OS, The problem recurs with fresh installation of Tor, and the problem does not effect obfs4, which is the only other plugable transport that shows in the configuration options.

comment:2 Changed 5 weeks ago by dcf

Cc: gk added
Description: modified (diff)

Thanks for taking the time to make this report.

gk: is there planned to be a 8.5.6 release (using the XPCOM meek-http-helper), or is the next stable release going to be 9.0 (using obfs4proxy meek_lite)?

If there's going to be another stable release using this code, then I'll try to solve it. But if not, the issue is moot, seeing as the affected code doesn't exist in obfs4proxy nor even in meek-http-helper anymore.

The instanceof line is from 2015, so I wonder why we are only getting reports about errors now. Possibly something about the API for nsIXPCException changed in Firefox recently.

bakertaylor28: The reason I asked gk about release is that this code is already not being used in Tor Browser alpha releases, and won't be used in future stable releases either. This is because new releases no longer use the headless browser for TLS camouflage (#29430), and because even the headless browser support code in meek was rewritten for the newer WebExtension standard (#29347).

comment:3 Changed 5 weeks ago by gk

There is no further stable release planned based on 8.5. The next one should be 9.0.

comment:4 in reply to:  3 Changed 5 weeks ago by dcf

Resolution: wontfix
Status: newclosed

Replying to gk:

There is no further stable release planned based on 8.5. The next one should be 9.0.

Thanks. In that case I don't think there is much sense in spending time to fix this.

bakertaylor28, I hope that an alpha release will work for you, until 9.0 is released.

comment:5 Changed 5 weeks ago by dcf

Just noting that a Reddit user reported the same problem today.

https://www.reddit.com/r/TOR/comments/dgb76e/problem_with_meekazure_not_working_is_it_down/

comment:6 Changed 5 weeks ago by bakertaylor28

Thanks. I just wasn't exactly sure what was going on with this, or for that matter whether or not that script was even supposed to be there.

comment:7 Changed 4 weeks ago by bakertaylor28

Interesting thing is that the problem has seemed to have spontaneously fixed itself without intervention.

Note: See TracTickets for help on using tickets.