Opened 4 months ago

Closed 3 months ago

Last modified 3 months ago

#32039 closed defect (fixed)

Tor Browser 8.5.5 is not working on macOS 10.15 after being freshly installed on macOS 10.15

Reported by: gk Owned by: tbb-team
Priority: Very High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: TorBrowserTeam201910
Cc: Actual Points: 0.25
Parent ID: Points:
Reviewer: Sponsor:

Description

Probably due to missing notarization Tor Browser stable is not working after being freshly installed on a macOS 10.15 system. Symptoms are that the browser is starting up but there is no Tor Launcher wizard visible and the proxy server is refusing connections.

Child Tickets

Change History (5)

comment:1 Changed 4 months ago by gk

FWIW, our alpha bundles work fine. This is just the ticket for our stable issues.

comment:2 Changed 3 months ago by mcs

I went through a bunch of scenarios this morning and could not reproduce the problems that have been reported. I also tried resetting the macOS gatekeeper settings to their defaults and testing again to make sure old settings were not present that were granting privileges that allowed 8.5.5 to work on my test system. (side note: I am not sure how to verify that everything was reset.)

But now I wonder if people are doing something different than I did, such as copying TB into /Applications but sometimes running an ESR60-based Tor Browser and sometimes an ESR68-based one? Problems will occur if you downgrade and run an ESR60-based browser with an ESR68-based profile; when I did that once by accident I saw that Torbutton was not present after starting TB 8.5.5.

Here are my detailed notes:

Scenario 1: Installed TB 8.5.5 into a new folder on the desktop.

  • Answered prompt: "Tor Browser is an app downloaded from the Internet. Are you sure you want to open it?"
  • Browser started up and worked correctly.

Scenario 2: Installed TB 8.5.5 into /Applications.

  • Same steps and results as for scenario 1.

Scenario 3: Installed TB 9.0a4 into a new folder on the desktop.

  • Saw error alert: "Tor Browser can't be opened because Apple cannot check it for malicious software."
  • Used Ctrl-Click|Open to override the block.
  • Browser started up and worked correctly.
  • Used the built-in updater to update to TB 9.0a7.
  • Browser started up and worked correctly.

Scenario 4: Installed TB 9.0a4 into /Applications.

  • Same steps and results as for scenario 3.

I then did the following and then re-tested all four scenarios:

  • sudo spctl --reset-default
  • sudo reboot
  • rm -rf ~/Library/Application\ Support/TorBrowser-Data

comment:3 Changed 3 months ago by mcs

I forgot to mention that I do not know why trying to open TB 8.5.5 for the first time causes the old style prompt to be shown while opening TB 9.0a4 shows the newer prompt.

Last edited 3 months ago by mcs (previous) (diff)

comment:4 Changed 3 months ago by gk

Resolution: fixed
Status: newclosed

Thanks for the investigation. I am closing this as 9.0 as about to get built.

comment:5 Changed 3 months ago by mcs

Actual Points: 0.25
Note: See TracTickets for help on using tickets.