Opened 5 weeks ago

Last modified 4 weeks ago

#32071 new defect

Remove perl scripts from development process?

Reported by: nickm Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by teor)

There are a few perl5 scripts in our development process:

[1099]$ git grep /usr/bin/perl
 [...]
contrib/or-tools/checksocks.pl:#!/usr/bin/perl -w
scripts/coccinelle/test-operator-cleanup:#!/usr/bin/perl -w -p -i
scripts/codegen/gen_linux_syscalls.pl:#!/usr/bin/perl -w
scripts/maint/checkLogs.pl:#!/usr/bin/perl -w
scripts/maint/checkOptionDocs.pl.in:#!/usr/bin/perl -w
scripts/maint/checkSpace.pl:#!/usr/bin/perl
scripts/maint/check_config_macros.pl:#!/usr/bin/perl -w
scripts/maint/findMergedChanges.pl:#!/usr/bin/perl
scripts/maint/updateCopyright.pl:#!/usr/bin/perl -i -w -p
scripts/test/cov-exclude:#!/usr/bin/perl -p -i

We could do any of the following:

  • Declare that perl5 is lovely and we don't care.
  • Declare that perl5 is ugly but not really a problem.
  • Declare that we will no longer require perl, and migrate all of these scripts to python and/or bash+sed+awk+etc
  • Declare that we will only allow perl as a "better sed/awk", and migrate all of the more complex scripts to python and/or bash+sed+awk, but leaves the others asd perl.

I am excluding these possibilities, but the imp of the perverse demands that I mention them:

  • Migrate to perl6 ^W raku

Child Tickets

Change History (1)

comment:1 Changed 4 weeks ago by teor

Description: modified (diff)
Note: See TracTickets for help on using tickets.