Opened 9 years ago

Closed 8 years ago

#3211 closed defect (not a bug)

Orbot won't start on Nexus 2.3.4

Reported by: n8fr8 Owned by: ioerror
Priority: Medium Milestone:
Component: Applications/Orbot Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

nexus one

anroid 2.3.4
build grj22

Child Tickets

Change History (9)

comment:1 Changed 9 years ago by ioerror

I/ORBOT   ( 3007): service started:
I/ActivityManager(   92): Displayed org.torproject.android/.Orbot: +367ms
I/ORBOT   ( 3007): service started:
I/ORBOT   ( 3007): service started:

comment:2 Changed 9 years ago by ioerror

Data cleared, debugging enabled, wizard setup without root and starting Tor:

I/ORBOT   ( 3545): service started:
org.torproject.android.service.TOR_SERVICE
D/ORBOT   ( 3545): Tor binary exists=false
D/ORBOT   ( 3545): Privoxy binary exists=false
D/ORBOT   ( 3545): SUCCESS: installed tor, privoxy binaries from raw
I/ActivityManager(   92): Displayed org.torproject.android/.Orbot: +2s556ms
I/ORBOT   ( 3642): service started:
org.torproject.android.service.TOR_SERVICE
D/ORBOT   ( 3642): Tor binary exists=false
D/ORBOT   ( 3642): Privoxy binary exists=false
D/ORBOT   ( 3642): SUCCESS: installed tor, privoxy binaries from raw
I/ActivityManager(   92): Displayed org.torproject.android/.Orbot: +2s447ms
I/ORBOT   ( 3642): service started:
org.torproject.android.service.TOR_SERVICE
I/ORBOT   ( 3642): service started:
org.torproject.android.service.TOR_SERVICE

comment:3 Changed 9 years ago by ioerror

Is there anything you'd like me to do to debug this issue Nathan?

comment:4 Changed 9 years ago by n8fr8

Status: newaccepted

We will have dev build available shortly that will provide more information about problems occuring during the binary install process.

In the meantime, can you verify that the apps data path is /data/data/org.torproject.android ?

comment:5 Changed 9 years ago by n8fr8

so far cannot reproduce on Nexus One using AOSP 2.3.4 ROM

comment:6 Changed 9 years ago by n8fr8

Owner: changed from n8fr8 to ioerror
Status: acceptedassigned

@ioerror - can you try installing previous version and let me know if that works?

https://guardianproject.info/downloads/0.2.2.22-alpha-orbot-1.0.4.1.apk (.asc)

comment:7 Changed 9 years ago by n8fr8

tested 1.0.5.2 on Acer Android 3.0.1 tablet unrooted and it worked fine.

comment:8 Changed 9 years ago by ioerror

I've found that if I reboot the phone, Orbot starts on boot automatically and does not have this issue.

comment:9 Changed 8 years ago by cwt96

Resolution: not a bug
Status: assignedclosed
Note: See TracTickets for help on using tickets.