Opened 4 weeks ago

Closed 3 weeks ago

#32141 closed defect (duplicate)

single onion v3 IPv6 intro circuit BUG() warnings

Reported by: teor Owned by: dgoulet
Priority: Medium Milestone: Tor: 0.4.2.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: 042-should, ipv6, tor-hs
Cc: asn Actual Points:
Parent ID: Points: 1
Reviewer: Sponsor: Sponsor27-must

Description

Looks like some of our assertions are wrong in single onion IPv6 mode, but chutney still succeeds:

Warning: Bug: Tor 0.4.3.0-alpha-dev (git-d616214e474084fd): Non-fatal assertion !(!hs_ident_intro_circ_is_valid(circ->hs_ident)) failed in intro_circ_is_ok at src/feature/hs/hs_client.c:491. Stack trace: (on Tor 0.4.3.0-alpha-dev d616214e474084fd) Number: 1
Warning: Bug: Tor 0.4.3.0-alpha-dev (git-d616214e474084fd): Non-fatal assertion !(desc == NULL) failed in setup_intro_circ_auth_key at src/feature/hs/hs_client.c:685. Stack trace: (on Tor 0.4.3.0-alpha-dev d616214e474084fd) Number: 1
Warning: tor_bug_occurred_: Bug: src/feature/hs/hs_client.c:491: intro_circ_is_ok: Non-fatal assertion !(!hs_ident_intro_circ_is_valid(circ->hs_ident)) failed. (Future instances of this warning will be silenced.) (on Tor 0.4.3.0-alpha-dev d616214e474084fd) Number: 1
Warning: tor_bug_occurred_: Bug: src/feature/hs/hs_client.c:685: setup_intro_circ_auth_key: Non-fatal assertion !(desc == NULL) failed. (Future instances of this warning will be silenced.) (on Tor 0.4.3.0-alpha-dev d616214e474084fd) Number: 1

https://travis-ci.org/torproject/tor/jobs/599435523#L3431

Child Tickets

Change History (3)

comment:1 Changed 4 weeks ago by dgoulet

Cc: dgoulet removed
Sponsor: Sponsor27-must

comment:2 Changed 3 weeks ago by dgoulet

Owner: set to dgoulet
Status: newassigned

comment:3 Changed 3 weeks ago by dgoulet

Resolution: duplicate
Status: assignedclosed

Very confusing stacktrace... It goes from client sending the INTRO1 cell and ends with channel tls handle cell function... weird.

But, I'm unable to reproduce that with the single-onion-v23-ipv6-md chutney network config (which I believe is the one that created this log). (I hammered loop the test to try to stress it.)

One of these assert()s is #28970 which was very recently fixed so I think that could be the root of this entire set of Bug(). And we know that this bug created more assert() down the code path of the whole HS introduction.

My money here would be that it is fixed and we shouldn't see this anymore.

I'm closing since I have no action items and I strongly think #28970 is the root cause.

Note: See TracTickets for help on using tickets.