Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#32149 closed defect (not a bug)

Grey bars on resized Tor Browser window

Reported by: Zarko_Gjurov Owned by:
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In alpha 9.0.8 when user resizes the window of Tor Browser, then grey bars are around the window from inside, is that a new undocumented feature or is a bug?

Child Tickets

Change History (3)

comment:1 Changed 3 months ago by gk

Resolution: not a bug
Status: newclosed

It's a feature, called letterboxing, to defend against fingerprinting of your screen dimensions. It got even press coverage: https://www.zdnet.com/article/firefox-to-add-tor-browser-anti-fingerprinting-technique-called-letterboxing/.

comment:2 Changed 3 months ago by gk

Component: Core TorApplications/Tor Browser

comment:3 Changed 3 months ago by Thorin

There's a lot of inaccuracies in that article, but how letterboxing works is pretty much on point :)

Note: See TracTickets for help on using tickets.