Opened 4 weeks ago

Closed 4 weeks ago

Last modified 3 weeks ago

#32154 closed defect (fixed)

Tor Launcher's custom bridge field only allows one line of input

Reported by: mcs Owned by: brade
Priority: Medium Milestone:
Component: Applications/Tor Launcher Version:
Severity: Normal Keywords: ff68-esr, TorBrowserTeam201910R
Cc: Actual Points: 0.5
Parent ID: Points: 0.5
Reviewer: Sponsor:

Description

In the ESR68-based Tor Browser, Tor Launcher's custom bridge input field only allows one line of input. Some detective work reveals that Mozilla was in the process of removing XUL textbox during the ESR68 cycle and now it has been completely removed (for Firefox 71):
https://bugzilla.mozilla.org/show_bug.cgi?id=1513325

They have switched everything to use html:input and html:textarea and we will need to do the same, eventually. Prior to ESR68, they removed support for multiline textbox elements, which is the cause of the custom bridge field breakage.

We are working on a fix, although I guess it is too late for Tor Browser 9.0? I wish we would have noticed this sooner.

Child Tickets

Change History (4)

comment:1 Changed 4 weeks ago by gk

Not sure yet if it's too late. I am inclined to ship it in 9.0.1 instead of redoing our builds. Either way we could include it in 9.5a1 to give it more testing if you'd give me a patch today-ish. :)

comment:2 Changed 4 weeks ago by mcs

Keywords: TorBrowserTeam201910R added; TorBrowserTeam201910 removed
Status: newneeds_review

Here is a fix:
https://gitweb.torproject.org/user/brade/tor-launcher.git/commit/?h=bug32154-01&id=954c1d290e68fd1b621a4fb6ab3ffce6059bab5f

To answer a question that was asked on IRC: if someone already has more than one bridge line, the lines will be combined into one when the Tor Launcher setup wizard is opened and the user tries to save the configuration. That means saving the config will fail. The good news is that the new about:preferences Tor settings UI works correctly, and most users will not see the setup wizard unless bootstrapping fails (or if they press Cancel during bootstrapping).

comment:3 Changed 4 weeks ago by gk

Resolution: fixed
Status: needs_reviewclosed

Okay, I convinced myself to do a build2 to pick this fix up. Your patch looks good to me and works on my Linux box. Applied to master (commit d3c66f516b07271ea4bb5f2481d9e02ff912b0ce).

To save some time and another round trip I took the liberty to change the patch slighty having textarea mentioned as an element for which a strings gets returned as well:

+// string (textarea, textbox, and menulist).

Thanks!

comment:4 Changed 3 weeks ago by mcs

Actual Points: 0.5
Note: See TracTickets for help on using tickets.