Opened 3 months ago

Closed 3 months ago

#32202 closed defect (not a bug)

white header and footer

Reported by: rsstnce17 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version: Tor: 0.4.1.6
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

seems to be a white header and footer on every page after i updated...

Child Tickets

Attachments (1)

torimg.png (219.5 KB) - added by rsstnce17 3 months ago.

Download all attachments as: .zip

Change History (4)

Changed 3 months ago by rsstnce17

Attachment: torimg.png added

comment:1 Changed 3 months ago by Thorin

Do you have any of all of the following

  • DPI not at 100 see #30625
  • The bookmarks toolbar showing and/or you chose a different theme density - see #27845
  • Are on Linux and the desktop environment causes it see #30970

New windows are meant to be created at 1000px wide and in 100px height up to 1000px (if your available screen resolution allows it). But it's not perfect, and often the height is screwed up (usually several pixels too short). This is problematic to fix.

Since its hard to fix, and we can't stop users accidentally (or willingly) changing the window size, or going full screen/maximized, or toggling on/off various chrome elements (usability) etc, we introduced Letterboxing which automagically wraps your inner window content into rounded sizes

This is the pref privacy.resistFingerprinting.letterboxing which protects you from all those weird sizes that can help make you more unique, as well as allowing you better usability (by stepping the sizing to allow the maximum use of inner window real estate -> users who resize the browser are now going to fall into buckets of sizes)

I suspect this is what you are seeing, as long as your new tor window is not hitting the top and bottom of the screen which (and IANA expert) seems to be happening on Mac see #32138 but I'm not a Mac person and this maybe also be caused by some tiling OS function (IDK)

comment:2 Changed 3 months ago by Thorin

Keywords: tbb-fingerprinting-resolution added; white header footer removed
Status: newneeds_information

comment:3 Changed 3 months ago by Thorin

Keywords: tbb-fingerprinting-resolution removed
Resolution: not a bug
Status: needs_informationclosed

as long as your new tor window is not hitting the top and bottom of the screen

OK, sorry, OP provided a screenshot. This is letterboxing

Note: See TracTickets for help on using tickets.