Opened 7 weeks ago

Closed 7 weeks ago

Last modified 6 weeks ago

#32215 closed defect (not a bug)

tor browser goes black when starting

Reported by: carlosnewmusic Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

when starting tor in linux both the connection interface will turn black from the beginning, without even differentiating between the title bar and the program

Child Tickets

Attachments (1)

capture.cleaned.png (39.8 KB) - added by carlosnewmusic 7 weeks ago.
open tor browser

Download all attachments as: .zip

Change History (9)

Changed 7 weeks ago by carlosnewmusic

Attachment: capture.cleaned.png added

open tor browser

comment:1 Changed 7 weeks ago by gk

Keywords: tbb-9.0-issues added; tor browser black removed
Priority: ImmediateHigh
Status: newneeds_information
Version: Tor: 0.4.1.6

Are you using torbrowser-launcher? We had some report on IRC that mentioned torbrowser-launcher's AppArmor blocking access to /dev/shm/org.mozilla.*.* is responsible for that.

comment:2 Changed 7 weeks ago by PeterG.

I*ve got the same problem.
I'm using debian buster and torbrowser-launcher.
I can try to edit the appamor profiles, if you tell me how.

comment:3 Changed 7 weeks ago by cypherpunks

I'm running Tor Browser with Apparmor profiles in enforced mode (confirmed with aa-status) and have no problems whatsoever.

However my profiles are very slight modifications of the ones from torbrowser-lancher's devel branch. What I modify is only the paths because I don't use torbrowser-launcher and have the bundle in a different directory.

Maybe it has something to with that. Although if the paths were wrong then the profiles wouldn't even apply. Or maybe the devel branch on github has a different profile than what people have installed on their systems.

comment:4 Changed 7 weeks ago by gk

Keywords: tbb-9.0-issues removed
Resolution: not a bug
Status: needs_informationclosed

Seems to be a torbrowser-launcher bug actually.

comment:5 Changed 7 weeks ago by nirgal

Last edited 7 weeks ago by nirgal (previous) (diff)

comment:7 Changed 7 weeks ago by PeterG.

I applied the two line from boklms posting to the Apparmore profile. Now everything works pretty fine.
Thank you!

comment:8 Changed 6 weeks ago by carlosnewmusic

https://github.com/micahflee/torbrowser-launcher/issues/436 I have already reported it there, because even modifying those two lines still works out the same with both the current stable version and with the alpha

Note: See TracTickets for help on using tickets.