Opened 6 weeks ago

Closed 6 weeks ago

#32221 closed defect (worksforme)

tor launcher extension intergation into browser is not for everyone

Reported by: mfD1TuzasD32GvaI3mh6 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have applications other then tor browser connecting to tor core.
I have core running all the time and used to disable tor launcher and had tor browser connecting directly to separate tor core.
Now tor browser 9.0 has launcher integrated into browser with no way to turn off, it seams; changing flag "extensions.torlauncher.start_tor" in about:config just pins my CPU at 100% and browser does not even try to make connection to localhost:9050.
i can see 2 workarounds:
1) set one of local ports to something other then 9050 and have 2 tors running while browsing web
2) have tor browser running all the time and have everything connect trough it.
Each of the methods will consume extra resources when not necessary.
I wish there was a simple way to turn off launcher in browser like it always has been in past.

Child Tickets

Change History (11)

comment:1 Changed 6 weeks ago by cypherpunks

Yeah this so called tor project is being a jerk all the time.

Seriously, I want to + on this issue. HELP! Developers!

comment:2 Changed 6 weeks ago by cypherpunks

in 8.5:

  1. Set use-nontor-proxy to true in aooutconfig
  2. Set custom proxy
  3. Disable tor addons from about:addons
  4. I can use TBB with my own proxy

in 9:

  1. Super headache

What the hell developers? No donation for next year I thinnk!

comment:3 Changed 6 weeks ago by gk

Resolution: invalid
Status: newclosed

You can still skip Tor Launcher managing Tor by setting TOR_SOCKS_PORT, TOR_CONTROL_PORT, and TOR_SKIP_LAUNCH (+ TOR_CONTROL_COOKIE_AUTH_FILE) accordingly. There has nothing changed in that regard. In fact, I tested it a couple of minutes ago and I can still use my system Tor that way. So, it's not true that there is no way to turn off Tor Launcher's functionality.

comment:4 Changed 6 weeks ago by cypherpunks

Resolution: invalid
Status: closedreopened

How do I do that in Windows?

And I don't want to edit OS's default values.

Why don't you respect about:config's values anymore?

comment:5 Changed 6 weeks ago by cypherpunks

In Windows + 8.5, disabing tor was SUPER EASY.

Above comment 2,

What the hell guys?

comment:6 Changed 6 weeks ago by mfD1TuzasD32GvaI3mh6

@gk first, i'd like to thank you for taking a time to answer my ticket.

i have followed your instructions by exporting listed values in tor-browser shortcut. this disables launcher and browser connects to running proxy as expected, however I am greeted with red welcome screen "something went wrong".
I could ignore this, but main issue is that CPU gets pinned at max with process firefox.real
I am on Ubuntu variant 16.04.

@cypherpunks, please be nice, we both want the same here, but there is no need for insults and threats;

comment:7 in reply to:  4 Changed 6 weeks ago by gk

Replying to cypherpunks:

How do I do that in Windows?

And I don't want to edit OS's default values.

Why don't you respect about:config's values anymore?

In Windows you can set environment variables as well. That said I don't see a reason why the pref based approach is not working to use a *system tor*. In fact, I just tested that and it works for me on my Linux system.

comment:8 in reply to:  6 Changed 6 weeks ago by gk

Keywords: laucher browser removed
Status: reopenedneeds_information
Version: Tor: unspecified

Replying to mfD1TuzasD32GvaI3mh6:

@gk first, i'd like to thank you for taking a time to answer my ticket.

i have followed your instructions by exporting listed values in tor-browser shortcut. this disables launcher and browser connects to running proxy as expected, however I am greeted with red welcome screen "something went wrong".

As written in my previous comment, you could even use the preferences available for that. You get the red welcome screen because Tor Browser can's check via the control port whether tor is running and ready. Do you have cookie authentication enabled in your system tor?

I could ignore this, but main issue is that CPU gets pinned at max with process firefox.real
I am on Ubuntu variant 16.04.

That's just with using a system Tor? And it does not happen with Tor Browser 8.5.5?

comment:9 Changed 6 weeks ago by gk

Oh, and we actually heard that the guide someone made a while ago for using a system Tor is actually working again (while it was not so before). So, yay!

comment:10 Changed 6 weeks ago by mfD1TuzasD32GvaI3mh6

thanks for link to guide.
I do use passwd_auth not cookie_auth. With help of the guide I learned how to export correct variable for passwd_auth. And everything works now the way I'd expect - no red screen, no CPU overload.

In 8.5.5 there was no need to teach browser about control port - everything work without it, with exception of setting up new circuits. If i needed to do so, I just used arm.

Since in your post you did say "export those variable,... There has nothing changed in that regard.",
I didn't bother setting up TOR_CONTROL_COOKIE_AUTH_FILE, coz I knew i use PASSWD, but did't know how to export variable accordingly. I understood this part didn't change, so I expected same behavior with 9.0

This is probably irrelevant now, but
yes, CPU overload did only happened using system tor
correct this did not happen with 8.5.5

Bottom line of the issue:
8.5.5 did not care about control port so much - no red screen no CPU overload
9.0 does and causes issues if control port not configured.

There was some misunderstanding caused by lack of my knowledge. I do apologize and I am very thankful for all your help.

comment:11 Changed 6 weeks ago by gk

Resolution: worksforme
Status: needs_informationclosed

Glad you got it working.

Note: See TracTickets for help on using tickets.