Opened 10 months ago

Closed 10 months ago

Last modified 8 months ago

#32229 closed defect (not a bug)

Websites Rendered with Border Within TOR Window

Reported by: TornadoGR1 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: ggus Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

With the update to v9.0 all websites render in the TOR browser with a border within the window and the scroll bar inset from the right-hand border of the window. Please see the attached screen capture.

Child Tickets

Attachments (1)

Capture.JPG (327.7 KB) - added by TornadoGR1 10 months ago.
Screenshot

Download all attachments as: .zip

Change History (4)

Changed 10 months ago by TornadoGR1

Attachment: Capture.JPG added

Screenshot

comment:1 Changed 10 months ago by ggus

Component: WebpagesApplications/Tor Browser
Owner: set to tbb-team
Resolution: not a bug
Status: newclosed

Tor Browser in its default mode is starting with a content window rounded to a multiple of 200px x 100px to prevent fingerprinting the screen dimensions. The strategy here is to put all users in a couple of buckets to make it harder to single them out. That worked so far until users started to resize their windows (e.g. by maximizing them or going into fullscreen mode). Tor Browser 9 ships with a fingerprinting defense for those scenarios as well, which is called Letterboxing, a technique developed by Mozilla and presented earlier this year. It works by adding white margins to a browser window so that the window is as close as possible to the desired size while users are still in a couple of screen size buckets that prevent singling them out with the help of screen dimensions.

comment:2 Changed 8 months ago by blochberger

Is there a way to disable this feature, e.g., through the advanced configuration if one accepts the risk?

comment:3 in reply to:  2 Changed 8 months ago by pili

Replying to blochberger:

Is there a way to disable this feature, e.g., through the advanced configuration if one accepts the risk?

Not yet, see #32325 for plans to do enable this

Note: See TracTickets for help on using tickets.