Opened 9 years ago

Closed 9 years ago

#3226 closed defect (fixed)

Screen orientation change ends configuration wizard

Reported by: djhalliday Owned by: n8fr8
Priority: Medium Milestone:
Component: Applications/Orbot Version:
Severity: Keywords:
Cc: gsathya.ceg@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

moved from github issue #6 (https://github.com/guardianproject/Orbot/issues/6)

Last reproduced on Orbot-1.0.5.2 on CM-7.05132011-NIGHTLY-N1

When the screen orientation changes while the configuration wizard is active, the user gets dropped into the Orbot main activity screen. There seems to be no way to resume the wizard. This does not seem to impair any of Orbot's functions.

I observed the same issue with other pop-up activities like the first Tor connection confirmation.

Child Tickets

Change History (2)

comment:1 Changed 9 years ago by gsathya

Cc: gsathya.ceg@… added
Status: newneeds_review

Android restarts an activity when the screen orientation is changed. WizardHelper.java restarts every time, creating the dialogbox right from the first step.

Fixed : Complete re-write of the set up wizard. Now follows android guidelines by creating a separate activity for each step.

https://gitweb.torproject.org/user/gsathya/orbot.git/log/refs/heads/wizard

comment:2 Changed 9 years ago by n8fr8

Resolution: fixed
Status: needs_reviewclosed
Note: See TracTickets for help on using tickets.