Opened 12 months ago

Closed 5 months ago

#32268 closed defect (fixed)

second new onionoo backend

Reported by: weasel Owned by: karsten
Priority: Medium Milestone:
Component: Internal Services/Tor Sysadmin Team Version:
Severity: Normal Keywords: metrics-team-roadmap-2020
Cc: irl Actual Points:
Parent ID: #31659 Points: 2
Reviewer: Sponsor:

Description

Now that we know how to set up new onionoo backends, we can make another one. (Then we can retire the old ones.)

We'll probably want basically a copy of onionoo-backend-01, probably also on gnt-fsn.

irl can set it up eventually, but not in the next few days as he's otherwise engaged. However, if we get the instance set up soonish, he may find the time to set up the service in the next few weeks.

Child Tickets

Change History (12)

comment:1 Changed 12 months ago by weasel

So, just to clarify:

next step: set up VM (tsa).
then: irl to set up service.

comment:2 Changed 11 months ago by anarcat

Component: - Select a componentInternal Services/Tor Sysadmin Team
Owner: set to tpa

comment:3 Changed 8 months ago by weasel

Cc: irl added

onionoo-backend-02.torproject.org set up and puppetized.

varnish is currently masked and puppet disabled so it does not re-enable varnish.

The frontends automatically picked up onionoo-backend-02.

Waiting for metrics/irl to set up onionoo software now.

comment:4 Changed 8 months ago by anarcat

can this be setup soon? i'm hoping to decomission unifolium next week and omeiense is one of the boxes to migrate. from what i understand, it's to be replaced by this setup.

it would be great if I could just decomission omeiense instead, as it would save me a ton of work..

thanks!

comment:5 Changed 7 months ago by anarcat

Owner: changed from tpa to irl
Status: newassigned

i think this is waiting on the metrics people :)

comment:6 Changed 7 months ago by anarcat

actually, it's blocked on #33733 because they're having trouble reproducing our prod environment in dev. but once that's done, i think it *is* waiting on irl.

comment:7 Changed 7 months ago by gaba

Keywords: metrics-team-roadmap-2020April added
Points: 2

comment:8 Changed 7 months ago by irl

Keywords: irl-roadmap-2020April added

comment:9 Changed 6 months ago by gaba

Keywords: metrics-team-roadmap-2020 added; metrics-team-roadmap-2020April irl-roadmap-2020April removed

We need to review all this tickets for metrics roadmap.

comment:10 Changed 5 months ago by karsten

Owner: changed from irl to karsten
Status: assignedaccepted

Picking this up.

comment:11 Changed 5 months ago by karsten

I set up both onionoo-backend-01 and -02 using the data from omeiense and let them run the hourly updater over night. I think we can switch over to them, but I'd like to be around when we do that. I have to go AFK for a couple hours now. Can we maybe do the switch this afternoon at 14:00 UTC?

comment:12 Changed 5 months ago by karsten

Resolution: fixed
Status: acceptedclosed

All done here, I think. Closing. Thanks!

Note: See TracTickets for help on using tickets.