Opened 3 months ago

Closed 3 months ago

#32271 closed defect (duplicate)

Mac OSX Tor Browser 9.0 missing Request header origin

Reported by: stridentbean Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-9.0-issues, tbb-9.0.1-can, tbb-regression
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm running a hidden service on my raspberry pi. My pi is running a docker container with tor running version 0.4.1.6 although a few other pis have lower versions and still see this issue. On the pi I also run a few apis and a Vuejs application.

Previously while running version 8.5.5, when making http requests (I'm not using https), the request header origin was always supplied and my cross origin policy was fine. However, with 9.0.0 the request header origin is not passed via a standard http request. Then the Tor browser throws this, "Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://OMITTED.onion:3000/OMITTED/. (Reason: CORS header ‘Access-Control-Allow-Origin’ missing"

Was this an intentional change or a bug? Is there any settings I could change in the browser to alleviate this?

Child Tickets

Change History (2)

comment:1 Changed 3 months ago by ggus

Cc: traumschule trac-dip-importer ggus removed
Component: Webpages/WebsiteApplications/Tor Browser
Owner: changed from hiro to tbb-team

comment:2 Changed 3 months ago by gk

Keywords: tbb-9.0-issues tbb-9.0.1-can tbb-regression added
Resolution: duplicate
Status: newclosed

Duplicate of #32255.

Note: See TracTickets for help on using tickets.