Opened 9 months ago

Closed 9 months ago

#32404 closed defect (implemented)

Add a CFLG_OBSOLETE flag, and handle it at the confvar layer

Reported by: teor Owned by: nickm
Priority: Medium Milestone: Tor: 0.4.3.x-final
Component: Core Tor/Tor Version: Tor: 0.4.2.1-alpha
Severity: Normal Keywords: network-team-roadmap-november
Cc: gaba Actual Points: .1
Parent ID: #29211 Points: 1
Reviewer: teor Sponsor: Sponsor31-must

Description

Follow up to #32295 for 0.4.3.

nickm says:

My suggestion would be to change how OBSOLETE is implemented: it doesn't really make sense as a type. Instead, there should be an "empty" type for fields that can't be read or written, and a CFLG_OBSOLETE flag that causes these warnings. The CFLG_OBSOLETE flag should be handled at the confvar layer, I think.

This is a bug caused by sponsor 31, so it's a must-have.

Child Tickets

Change History (4)

comment:1 Changed 9 months ago by nickm

Actual Points: .1
Reviewer: teor
Status: assignedneeds_review

Here's my first attempt: ticket32404 with PR at https://github.com/torproject/tor/pull/1518

comment:2 Changed 9 months ago by teor

Status: needs_reviewneeds_revision

Looks good, feel free to merge once the comment has been updated to explain the difference between OBSOLETE and IGNORE.

comment:3 Changed 9 months ago by teor

I wrote some tests for obsolete options in #32295, they should also pass on master, even without #32295 or #32404.

Edit: I'll do extra tests that depend on #32295 and #32404 in a separate branch.

Last edited 9 months ago by teor (previous) (diff)

comment:4 Changed 9 months ago by nickm

Resolution: implemented
Status: needs_revisionclosed

Fixed comments and merged

Note: See TracTickets for help on using tickets.