Opened 5 weeks ago

Closed 5 weeks ago

#32449 closed defect (fixed)

Appveyor: OpenSSL version mismatch in unit tests, 2019 edition

Reported by: teor Owned by: teor
Priority: Medium Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version: Tor: 0.3.5.6-rc
Severity: Normal Keywords: tor-ci-fail, consider-backport-immediately, 035-backport, 040-backport, 041-backport, 042-backport
Cc: Actual Points: 0.1
Parent ID: Points: 0.5
Reviewer: Sponsor:

Description

crypto/openssl_version: [forking] 
  FAIL ../src/test/test_crypto.c:237: OpenSSL library version 1.1.1d did not begin with header version 1.1.1c.
  [openssl_version FAILED]

https://ci.appveyor.com/project/torproject/tor/builds/28757237/job/ul9m0fnglaqtw3oy?fullLog=true#L3511

Child Tickets

Change History (2)

comment:1 Changed 5 weeks ago by teor

Actual Points: 0.1
Status: assignedmerge_ready
Version: Tor: 0.3.5.6-rc

Installing OpenSSL fixes the issue.

Here is the PR:

The merge forward is clean, and master passes.

Test branches:

I'll wait for CI to pass on 0.3.5 before merging.

comment:2 Changed 5 weeks ago by teor

Milestone: Tor: 0.4.3.x-finalTor: 0.3.5.x-final
Resolution: fixed
Status: merge_readyclosed

Merged to 0.3.5 and later.

Note: See TracTickets for help on using tickets.