Opened 4 weeks ago

Closed 11 days ago

#32463 closed defect (fixed)

TypeError in practracker "includes.py" script

Reported by: opara Owned by:
Priority: Low Milestone: Tor: 0.4.3.x-final
Component: Core Tor/Tor Version:
Severity: Minor Keywords: BugSmashFund?
Cc: Actual Points: 0.1
Parent ID: Points:
Reviewer: Sponsor:

Description

When practracker finds a forbidden include, it causes a Python TypeError. Example:

user@computer:~/tor$ make check-includes
python3 ./scripts/maint/practracker/includes.py .
Unusual pattern permitted.h in ./scripts/maint/practracker/testdata
Forbidden include of lib/lock/compat_mutex.h at ./src/lib/evloop/eventqueue.h:8
Traceback (most recent call last):
  File "./scripts/maint/practracker/includes.py", line 285, in <module>
    main(sys.argv)
  File "./scripts/maint/practracker/includes.py", line 282, in main
    list_advisories=args.list_advisories)
  File "./scripts/maint/practracker/includes.py", line 240, in run_check_includes
    files in its enclosing directory.""".format(RULES_FNAME))
TypeError: 'Error' object is not callable
make: *** [check-includes] Error 1

This seems to be caused by an err() function being removed from the code sometime in the past, but the call to err() was never also removed.

Child Tickets

Change History (2)

comment:1 Changed 4 weeks ago by nickm

Milestone: Tor: 0.4.3.x-final

comment:2 Changed 11 days ago by teor

Actual Points: 0.1
Keywords: BugSmashFund? added
Resolution: fixed
Status: newclosed

Thanks, I fixed this in ab70c315bdd72ee7578b8b8ee4077172e0181f36 and merged it to master.

Note: See TracTickets for help on using tickets.