Opened 4 weeks ago

Closed 3 weeks ago

#32464 closed enhancement (duplicate)

Block non .onion requests in TOR Browser

Reported by: simonfrey Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version: Tor: unspecified
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

During visiting the onion service of the New York Times (https://www.nytimes3xbfgragh.onion) I experienced, that there is still clear net traffic going on.
In the certain example of the NYTimes it is different forms of trackers.

As I consider clear net traffic on a onion service as bug by the website, I thought about why not to block all non onion traffic on .onion sites.

For playing around and checking if that idea breaks the websites I developed a small webextension implementing the described request-blocking: https://github.com/simonfrey/onion-only CC0

The sites I tested work all as expected and are not influenced in a bad UX way. I tried:

Looking forward to hear thoughts on the idea and if that could be an enhancement landing in the TOR Browser at some point.

Child Tickets

Change History (2)

comment:1 Changed 4 weeks ago by arma

Component: Webpages/WebtoolsApplications/Tor Browser
Owner: changed from hiro to tbb-team

wasn't there an option inside https everywhere for this approach? or am i imagining that?

comment:2 Changed 3 weeks ago by pili

Resolution: duplicate
Status: newclosed

Duplicate of #28174

Note: See TracTickets for help on using tickets.