Opened 9 months ago

Closed 6 months ago

#32467 closed defect (implemented)

Document tor's --dump-config command in the man page

Reported by: teor Owned by: nickm
Priority: Medium Milestone: Tor: 0.4.3.x-final
Component: Core Tor/Tor Version: Tor: 0.3.2.1-alpha
Severity: Normal Keywords: 042-backport-maybe, consider-backport-immediately, 043-can
Cc: Actual Points: 0
Parent ID: #29211 Points: 0.1
Reviewer: ahf Sponsor:

Description

I went to find the documentation for tor --dump-config today, but there's nothing in the man page.

Nick, can you do a quick man page update?
I think you wrote tor --dump-config in 0.3.2 ?

Child Tickets

Change History (11)

comment:1 Changed 9 months ago by nickm

Possible documentation in ticket32467 with PR at https://github.com/torproject/tor/pull/1532.

I kinda forgot what non-builtin did, so I had to look at the code.

comment:2 Changed 9 months ago by nickm

Actual Points: 0
Status: assignedneeds_review

comment:3 Changed 9 months ago by ahf

Reviewer: ahf
Status: needs_reviewmerge_ready

Looks good to me.

comment:4 Changed 9 months ago by nickm

Resolution: implemented
Status: merge_readyclosed

Okay, merged to master. Teor, please reopen if you'd like this to say more?

comment:5 in reply to:  1 Changed 7 months ago by teor

Resolution: implemented
Status: closedreopened

Replying to nickm:

Possible documentation in ticket32467 with PR at https://github.com/torproject/tor/pull/1532.

I kinda forgot what non-builtin did, so I had to look at the code.

As far as I can tell, non-builtin and short are now synonyms.

Because when non-builtin passes config_dump(..., /* default_options */ NULL, ...), config_dump() replaces NULL with a newly-allocated copy of the default options. Instead, it should replace them with a zeroed-out copy.

Can you give a command-line where non-builtin and short differ?

Here's what I tried:

tor --dump-config short
tor --dump-config non-builtin
tor --dump-config short SOCKSPort 0
tor --dump-config non-builtin SOCKSPort 0
tor --dump-config short SOCKSPort 1
tor --dump-config non-builtin SOCKSPort 1

(Also string-based options like Nickname and ContactInfo.)

comment:6 Changed 7 months ago by teor

I checked master, 0.4.2, and 0.4.1, and they all behave the same. So this might not even be a regression. (It's hard to tell without a counter-example.)

comment:7 Changed 7 months ago by teor

Status: reopenedneeds_revision

comment:8 Changed 7 months ago by nickm

Keywords: 043-can added

comment:9 Changed 7 months ago by gaba

Keywords: network-team-roadmap-november, 042-backport-maybe, consider-backport-immediately 043-cannetwork-team-roadmap-november, 042-backport-maybe, consider-backport-immediately, 043-can
Sponsor: Sponsor31-can

Sponsor closed. Remove from roadmap.

comment:10 Changed 7 months ago by gaba

Keywords: network-team-roadmap-november removed

comment:11 Changed 6 months ago by nickm

Resolution: implemented
Status: needs_revisionclosed

I've opened #33398 to address the situation with non-builtin

Note: See TracTickets for help on using tickets.