#32482 closed defect (duplicate)

Tor browser doesn't load, blank screen

Reported by: rerunner Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version: Tor: unspecified
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hello,

My Tor browser bundle has recently stopped loading. When running the launcher, the "Connect to Tor" window opens but never completely loads, and I only see a blank screen (screenshot attached). There are many AppArmor "DENIED" messages in /var/log/syslog, here's a snippet:

Launching Tor Browser.

Running /home/<user>/.local/share/torbrowser/tbb/x86_64/tor-browser_en-US/start-tor-browser.desktop

audit: type=1400 audit(1573611720.279:30): apparmor="DENIED" operation="capable" profile="torbrowser_firefox" pid=5055 comm="firefox.real" capability=21 capname="sys_admin"

audit: type=1400 audit(1573611722.971:31): apparmor="DENIED" operation="exec" profile="torbrowser_firefox" name="/usr/bin/lsb_release" pid=5080 comm="firefox.real" requested_mask="x" denied_mask="x" fsuid=1000 ouid=0

audit: type=1400 audit(1573611727.451:32): apparmor="DENIED" operation="mknod" profile="torbrowser_firefox" name="/dev/shm/org.mozilla.ipc.5055.0" pid=5055 comm="firefox.real" requested_mask="c" denied_mask="c" fsuid=1000 ouid=1000

audit(1573611795.295:68): apparmor="DENIED" operation="capable" profile="/usr/bin/man" pid=5208 comm="man" capability=1 capname="dac_override"

I'm running Debian 10:

# cat /etc/os-release
PRETTY_NAME="Debian GNU/Linux 10 (buster)"
NAME="Debian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"

# uname -r
4.19.0-6-amd64

Also using torbrowser-launcher version 0.3.2. Please let me know if you need any further info.

Child Tickets

Attachments (1)

tor1.png (7.6 KB) - added by rerunner 12 months ago.
browser screenshot

Download all attachments as: .zip

Change History (2)

Changed 12 months ago by rerunner

Attachment: tor1.png added

browser screenshot

comment:1 Changed 12 months ago by arma

Component: Applications/Tor LauncherApplications/Tor Browser
Owner: changed from brade to tbb-team
Resolution: duplicate
Status: newclosed

Yep, this is a bug in the torbrowser-launcher program:

Your options are to (a) download actual tor browser from the actual tor website, (b) look at the pull request and patch the two apparmor lines yourself, or (c) wait for torbrowser-launcher to put out a new version.

Note: See TracTickets for help on using tickets.