Opened 8 years ago

Closed 8 years ago

#3249 closed defect (wontfix)

user javascript to detect the user's language preference

Reported by: phobos Owned by: phobos
Priority: Medium Milestone:
Component: Webpages/Website Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Use javascript to detect the user's language preference to point the 'download tor' link at the correct tor browser bundle for their language. If their language doesn't exist in a TBB, default to english.

Child Tickets

Change History (3)

comment:1 Changed 8 years ago by arma

Duplicate of #3248?

comment:2 in reply to:  1 Changed 8 years ago by phobos

Replying to arma:

Duplicate of #3248?

Nope, #3248 is for operating system. This is for language preference.

comment:3 Changed 8 years ago by phobos

Resolution: wontfix
Status: newclosed

closing. in discussions with jeremy, there is no way to do this without running some sort of serverside code to read the http headers. the apache autonegotiation of language should do this for us. it's clear we just need more pages translated and kept up to date.

Note: See TracTickets for help on using tickets.