Opened 3 weeks ago

Closed 2 weeks ago

#32497 closed task (fixed)

Think about changing update-channel name for nightly

Reported by: boklm Owned by: boklm
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-rbm, tbb-update, TorBrowserTeam201911R
Cc: mcs, brade, tbb-team Actual Points: 0.5
Parent ID: #18867 Points:
Reviewer: Sponsor:

Description

Currently we set var/torbrowser_update_channel to default for the nightly builds.

I see that Mozilla is using nightly for their nightly builds.

Maybe we could change it to nightly too.

It is possible however that changing this channel name has some effects on the build. One of them is the filename of the file containing the mar signing key, in toolkit/mozapps/update/updater/moz.build. However from a quick look, I didn't see other important changes that would be caused by using nightly as MOZ_UPDATE_CHANNEL.

Child Tickets

Change History (3)

comment:1 Changed 3 weeks ago by boklm

Cc: tbb-team added
Owner: changed from tbb-team to boklm
Status: newassigned

comment:2 Changed 2 weeks ago by boklm

Actual Points: 0.5
Keywords: TorBrowserTeam201911R added; boklm201911 TorBrowserTeam201911 removed
Status: assignedneeds_review

After looking at the uses of MOZ_UPDATE_CHANNEL, I didn't notice anything that would cause problems if we changed to use nightly as the channel name.

In my branch bug_32497 I added a patch for review which changes the nightly channel to nightly:
https://gitweb.torproject.org/user/boklm/tor-browser-build.git/commit/?h=bug_32497&id=111ff13d612e5bfc830f19b3a001136db6baf477

comment:3 Changed 2 weeks ago by gk

Resolution: fixed
Status: needs_reviewclosed

Looks good to me. Merged to master (commit 111ff13d612e5bfc830f19b3a001136db6baf477).

Note: See TracTickets for help on using tickets.