Opened 9 months ago

Closed 7 months ago

#32502 closed defect (fixed)

Decommission the non-IPv6 broker

Reported by: dcf Owned by: dcf
Priority: Medium Milestone:
Component: Circumvention/Snowflake Version:
Severity: Normal Keywords:
Cc: arlolra, cohosh, phw, dcf Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We switched the the Snowflake broker to an IPv6-capable host in comment:16:ticket:29258. Once it's established, we need to shut down the old one.

I propose to do the shutdown on or before 2019-12-01.

I think cohosh wanted to take some special care with the metrics log from the old broker.

Child Tickets

Change History (3)

comment:1 Changed 7 months ago by dcf

I stopped the snowflake-broker process on the non-IPv6 broker at 2020-01-02 17:12:00. I copied its logs to the new broker into the following directories, with a README:

  • /var/log/snowflake-broker.pre-29258/
  • /home/snowflake-broker/metrics.log.pre-29258/

My plan is to wipe the disk and unallocate the VM after a few days. Until then, we have the option of turning it back on, in case something unanticipated goes wrong with it turned off.

comment:2 Changed 7 months ago by dcf

I've now turned off the old broker. I haven't been able to delete the VM yet; the cause may be a problem with eclips.is. I've sent in a support request for it.

comment:3 Changed 7 months ago by dcf

Resolution: fixed
Status: assignedclosed

Support was able to delete the VPS for me.

Note: See TracTickets for help on using tickets.