Opened 2 months ago

Closed 2 months ago

#32575 closed defect (fixed)

CID 1455953: Resource leak in options_act_reversible()

Reported by: nickm Owned by: nickm
Priority: Medium Milestone: Tor: 0.4.3.x-final
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Normal Keywords: coverity
Cc: Actual Points: .1
Parent ID: Points: .1
Reviewer: teor Sponsor: Sponsor31-can

Description

 *** CID 1455953:  Resource leaks  (RESOURCE_LEAK)
/src/app/config/config.c: 1983 in options_act_reversible()
1977       tor_assert(*msg);
1978     
1979       options_rollback_log_transaction(log_transaction);
1980       options_rollback_listener_transaction(listener_transaction);
1981     
1982      done:
>>>     CID 1455953:  Resource leaks  (RESOURCE_LEAK)
>>>     Variable "listener_transaction" going out of scope leaks the storage it points to.
1983       return r;
1984     }

Child Tickets

Change History (3)

comment:1 Changed 2 months ago by nickm

Actual Points: .1
Reviewer: teor
Status: assignedneeds_review

comment:2 Changed 2 months ago by nickm

Closed #32594 as a duplicate of this.

comment:3 Changed 2 months ago by teor

Resolution: fixed
Status: needs_reviewclosed
Version: Tor: unspecified

Looks good to me.
Merged to master.

Merged #32575, #31939, #31548, #30344, #30258, #28970, #31091, and #32108 together.

Note: See TracTickets for help on using tickets.