Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#3265 closed defect (not a bug)

Relays publish on average more than 1 descriptor per hour

Reported by: karsten Owned by:
Priority: Medium Milestone: Tor: 0.2.3.x-final
Component: Core Tor/Tor Version: Tor: 0.2.2.22-alpha
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Today, I noticed that some relays publish more server descriptors than they should, which would be 1 or 2 per day. For example, tor26 and gabelmoo both publish on average 1 server descriptor per hour, most likely after the auto-naming script sends tor a HUP signal.

Sebastian mentioned that this problem is probably related to #1810, but he also says that this bug was introduced in 0.2.2.6-alpha. However, from looking at the following list of published server descriptors by gabelmoo and tor26, it seems like the problem started with 0.2.2.22-alpha.

 gabelmoo | Tor 0.2.2.19-alpha (git-13e9a2b19d4a65d9) on Linux x86_64 | 2011-01-28 08:42:56
 gabelmoo | Tor 0.2.2.19-alpha (git-13e9a2b19d4a65d9) on Linux x86_64 | 2011-01-29 02:43:20
 gabelmoo | Tor 0.2.2.19-alpha (git-13e9a2b19d4a65d9) on Linux x86_64 | 2011-01-29 20:44:17
 gabelmoo | Tor 0.2.2.19-alpha (git-13e9a2b19d4a65d9) on Linux x86_64 | 2011-01-30 14:45:10
 gabelmoo | Tor 0.2.2.19-alpha (git-13e9a2b19d4a65d9) on Linux x86_64 | 2011-01-31 08:45:42
 gabelmoo | Tor 0.2.2.19-alpha (git-13e9a2b19d4a65d9) on Linux x86_64 | 2011-02-01 02:46:41
 gabelmoo | Tor 0.2.2.19-alpha (git-13e9a2b19d4a65d9) on Linux x86_64 | 2011-02-01 08:41:43
 gabelmoo | Tor 0.2.2.19-alpha (git-13e9a2b19d4a65d9) on Linux x86_64 | 2011-02-02 02:42:13
 gabelmoo | Tor 0.2.2.19-alpha (git-13e9a2b19d4a65d9) on Linux x86_64 | 2011-02-02 20:43:20
 gabelmoo | Tor 0.2.2.19-alpha (git-13e9a2b19d4a65d9) on Linux x86_64 | 2011-02-03 10:30:37
 gabelmoo | Tor 0.2.2.22-alpha (git-e5e38e55b33b2cc0) on Linux x86_64 | 2011-02-03 13:11:50
 gabelmoo | Tor 0.2.2.22-alpha (git-e5e38e55b33b2cc0) on Linux x86_64 | 2011-02-03 13:25:06
 gabelmoo | Tor 0.2.2.22-alpha (git-e5e38e55b33b2cc0) on Linux x86_64 | 2011-02-03 14:23:49
 gabelmoo | Tor 0.2.2.22-alpha (git-e5e38e55b33b2cc0) on Linux x86_64 | 2011-02-03 14:26:18
 gabelmoo | Tor 0.2.2.22-alpha (git-e5e38e55b33b2cc0) on Linux x86_64 | 2011-02-03 15:10:10
 gabelmoo | Tor 0.2.2.22-alpha (git-e5e38e55b33b2cc0) on Linux x86_64 | 2011-02-03 16:10:08
 gabelmoo | Tor 0.2.2.22-alpha (git-e5e38e55b33b2cc0) on Linux x86_64 | 2011-02-03 17:10:07
 gabelmoo | Tor 0.2.2.22-alpha (git-e5e38e55b33b2cc0) on Linux x86_64 | 2011-02-03 18:10:08
 gabelmoo | Tor 0.2.2.22-alpha (git-e5e38e55b33b2cc0) on Linux x86_64 | 2011-02-03 19:10:08
 gabelmoo | Tor 0.2.2.22-alpha (git-e5e38e55b33b2cc0) on Linux x86_64 | 2011-02-03 20:10:08

 tor26    | Tor 0.2.2.21-alpha (git-ba63b8afd8e49391) on Linux x86_64 | 2011-01-21 10:36:45
 tor26    | Tor 0.2.2.21-alpha (git-ba63b8afd8e49391) on Linux x86_64 | 2011-01-22 04:37:28
 tor26    | Tor 0.2.2.21-alpha (git-ba63b8afd8e49391) on Linux x86_64 | 2011-01-22 22:38:19
 tor26    | Tor 0.2.2.21-alpha (git-ba63b8afd8e49391) on Linux x86_64 | 2011-01-22 23:35:31
 tor26    | Tor 0.2.2.21-alpha (git-ba63b8afd8e49391) on Linux x86_64 | 2011-01-23 17:36:00
 tor26    | Tor 0.2.2.21-alpha (git-ba63b8afd8e49391) on Linux x86_64 | 2011-01-24 11:36:47
 tor26    | Tor 0.2.2.21-alpha (git-ba63b8afd8e49391) on Linux x86_64 | 2011-01-25 05:37:32
 tor26    | Tor 0.2.2.21-alpha (git-ba63b8afd8e49391) on Linux x86_64 | 2011-01-25 23:38:17
 tor26    | Tor 0.2.2.21-alpha (git-ba63b8afd8e49391) on Linux x86_64 | 2011-01-26 17:39:01
 tor26    | Tor 0.2.2.21-alpha (git-ba63b8afd8e49391) on Linux x86_64 | 2011-01-26 20:34:54
 tor26    | Tor 0.2.2.22-alpha (git-21b3de6cf37d4e60) on Linux x86_64 | 2011-01-26 20:35:40
 tor26    | Tor 0.2.2.22-alpha (git-21b3de6cf37d4e60) on Linux x86_64 | 2011-01-26 20:37:11
 tor26    | Tor 0.2.2.22-alpha (git-21b3de6cf37d4e60) on Linux x86_64 | 2011-01-26 20:51:48
 tor26    | Tor 0.2.2.22-alpha (git-21b3de6cf37d4e60) on Linux x86_64 | 2011-01-26 21:23:47
 tor26    | Tor 0.2.2.22-alpha (git-21b3de6cf37d4e60) on Linux x86_64 | 2011-01-26 22:24:01
 tor26    | Tor 0.2.2.22-alpha (git-21b3de6cf37d4e60) on Linux x86_64 | 2011-01-26 23:24:05
 tor26    | Tor 0.2.2.22-alpha (git-21b3de6cf37d4e60) on Linux x86_64 | 2011-01-27 00:23:57
 tor26    | Tor 0.2.2.22-alpha (git-21b3de6cf37d4e60) on Linux x86_64 | 2011-01-27 01:23:16
 tor26    | Tor 0.2.2.22-alpha (git-21b3de6cf37d4e60) on Linux x86_64 | 2011-01-27 02:23:17
 tor26    | Tor 0.2.2.22-alpha (git-21b3de6cf37d4e60) on Linux x86_64 | 2011-01-27 03:23:16

Child Tickets

Attachments (1)

task-3265-server-descriptors.tar.bz2 (1.9 MB) - added by karsten 9 years ago.
Server descriptors of relays that published 50+ server descriptors on 1 day in January 2012

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by karsten

Status: newneeds_information

Here's a quick SQL statement to see if this problem still exists. It does. There are some relays publishing 200 descriptors or more per day:

tordir=> SELECT date, numdescs, COUNT(*) FROM
  (SELECT DATE(published), COUNT(*) AS numdescs
  FROM descriptor WHERE published > '2011-07-22'
  GROUP BY fingerprint, DATE(published)) a
  GROUP BY 1, 2 HAVING numdescs >= 50 ORDER BY 1, 2;

    date    | numdescs | count 
------------+----------+-------
 2011-07-22 |       84 |     1
 2011-07-22 |      209 |     1
 2011-07-23 |       51 |     1
 2011-07-23 |       55 |     1
 2011-07-23 |       58 |     1
 2011-07-23 |      107 |     1
 2011-07-23 |      202 |     1
 2011-07-24 |       59 |     2
 2011-07-24 |       83 |     1
 2011-07-24 |      197 |     1
 2011-07-25 |       60 |     1
 2011-07-25 |       78 |     1
 2011-07-25 |      182 |     1
 2011-07-26 |      157 |     1
(14 rows)

comment:2 Changed 9 years ago by nickm

Milestone: Tor: 0.2.3.x-final

We should at least try to fix this in 0.2.3.x, if it's still happening.

comment:3 Changed 9 years ago by nickm

Can we do any analysis to see:

a) if this is still happening, and
b) what is different between all these hundreds of descriptors?

Changed 9 years ago by karsten

Server descriptors of relays that published 50+ server descriptors on 1 day in January 2012

comment:4 Changed 9 years ago by karsten

Resolution: not a bug
Status: needs_informationclosed

I looked at the server descriptors published between January 1 and 29, 2012 and found 16 distinct relays which published 50 server descriptors or more on a single day.

I then looked at the descriptors of these 16 relays to see how the descriptors changed. In total, I did 8463 pair-wise comparisons of server descriptors. In 2915 cases only the DirPort changed, in 2407 cases only the IP address changed, in 2474 cases both DirPort and IP address changed, in 614 cases the bandwidth line changed, and in only 53 cases there were other changes.

In summary, neither the absolute number of relays affected, nor the number of unusual other changes are worrisome to me. The problem seems to be fixed by now. Not sure what it was, but I concluded I shouldn't spend more time investigating.

The server descriptors of the 16 relays in question are attached if someone else wants to take a look.

Closing as not a bug.

comment:5 Changed 8 years ago by nickm

Keywords: tor-relay added

comment:6 Changed 8 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.