Opened 8 months ago

Closed 8 months ago

#32689 closed defect (not a bug)

control.py self.msg() calls try to join lists with strings

Reported by: kamin07 Owned by: atagar
Priority: Medium Milestone:
Component: Archived/Stem Version: Tor: 0.3.3.6
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In control.py, at the following instances, str is being concatenated with a list, which raises an exception:

  1. line 3129
  2. line 3557
  3. line 3952
  4. line 3972

Example: line 3129:
raise stem.ProtocolError('SETEVENTS rejected %s' % ', '.join(failed_events))

raises exception. Can be fixed by using:
raise stem.ProtocolError('SETEVENTS rejected %s' % ', '.join(str(v) for v in failed_events))

Child Tickets

Attachments (1)

Traceback.txt (1020 bytes) - added by kamin07 8 months ago.
Python Traceback

Download all attachments as: .zip

Change History (3)

Changed 8 months ago by kamin07

Attachment: Traceback.txt added

Python Traceback

comment:1 Changed 8 months ago by pastly

Component: ApplicationsCore Tor/Stem
Owner: set to atagar

comment:2 Changed 8 months ago by atagar

Resolution: not a bug
Status: newclosed

Hi kamin07. This is actually a bug in ScanHead.py. The call you're making is...

controller.add_event_listener(attach_stream, stem.response.events.StreamEvent)

As documented by add_event_listener the second argument are EventType, not the Event class. Please change this to...

from stem.control import EventType

controller.add_event_listener(attach_stream, EventType.STREAM)
Note: See TracTickets for help on using tickets.