Opened 8 months ago

Closed 7 months ago

Last modified 7 months ago

#32699 closed defect (fixed)

Rename the fallback input list to an "offer list"

Reported by: teor Owned by: teor
Priority: Medium Milestone:
Component: Core Tor/Fallback Scripts Version:
Severity: Normal Keywords: fallback
Cc: teor Actual Points:
Parent ID: #24839 Points: 0.5
Reviewer: Sponsor:


In #24839, we want to replace the list of relay operators who have offered their relays as fallbacks, with signed statements in descriptors via a torrc option.

As part of that transition, we should rename the internal variables in the script, and the file in the repository. I suggest we use "fallback offer list".

We should also delete any remaining references to the blacklist, because it is obsolete, and the actual list was removed from the repository some time ago.

This change also has the benefit of avoiding the "white = good" metaphor, which can be confusing and problematic. For more details, see:

Child Tickets

Change History (3)

comment:1 Changed 8 months ago by teor

Status: assignedneeds_review

See my code change:

And spec change:

The spec change also includes a spec for part of #24839, because I wanted to do the breaking changes all at once.

comment:2 Changed 7 months ago by teor

Resolution: fixed
Status: needs_reviewclosed

This is a simple change, it passes CI, and I'm the maintainer, so I merged it to fallback-scripts and torspec.

comment:3 Changed 7 months ago by teor

Unfortunately CI is failing for unrelated reasons, see #32959.

Note: See TracTickets for help on using tickets.