Opened 8 months ago

Closed 5 months ago

Last modified 5 months ago

#32749 closed defect (not a bug)

Tor download button on your site does nothing when I click on it

Reported by: get-lead-out.44mag Owned by: hiro
Priority: Very High Milestone:
Component: Webpages/Website Version:
Severity: Normal Keywords: ux-team
Cc: antonela Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm on cyberghost vpn and your TOR download button does absolutely nothing when I click on it. I have tried turning off firewall, malwarebytes, and tried using both Internet Explorer and Firefox browsers but still nothing happens when I click on your Tor download button and I can't find any search result which give a direct reason and solution to get Tor to download on our pc with Windows 8.1

Child Tickets

Change History (8)

comment:1 Changed 8 months ago by pili

Cc: antonela added
Keywords: ux-team added
Parent ID: #32460

The download button simply re-directs to the download page. You need to scroll down on this page to find the download link for your platform: linux, macOS or windows.

At the time of writing this, the direct link for windows is: https://www.torproject.org/dist/torbrowser/9.0.2/torbrowser-install-win64-9.0.2_en-US.exe and the signature file is: https://www.torproject.org/dist/torbrowser/9.0.2/torbrowser-install-win64-9.0.2_en-US.exe.asc

comment:2 Changed 8 months ago by pili

Component: ApplicationsWebpages/Website
Owner: set to hiro
Resolution: worksforme
Status: newclosed

comment:3 Changed 8 months ago by cypherpunks

Resolution: worksforme
Status: closedreopened

The download button simply re-directs to the download page.

This is a bad UX.

comment:4 Changed 8 months ago by pili

Resolution: not a bug
Status: reopenedclosed

We have #32460 to deal with download flow ux issues

comment:5 Changed 8 months ago by pili

Resolution: not a bug
Status: closedreopened

Re-opening after discussion during UX Team meeting.

We could potentially look at changing the button behaviour and we should discuss this further on this ticket

comment:6 Changed 6 months ago by antonela

Parent ID: #32460

unparenting - (not related)

comment:7 Changed 5 months ago by pili

Resolution: not a bug
Status: reopenedclosed

comment:8 Changed 5 months ago by cypherpunks

hah

Note: See TracTickets for help on using tickets.