#32761 closed defect (fixed)

Build of go fails on android builds

Reported by: boklm Owned by: tbb-team
Priority: Very High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: TorBrowserTeam201912, tbb-rbm
Cc: sisbell Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The latest nightly builds are failing when building go for android on all architectures:
http://f4amtbsowhix7rrf.onion/reports/r/tor-browser-2019-12-14/tor-browser_build.html

The go build logs contain:

Installed Go for linux/amd64 in /var/tmp/build/go1.4
Installed commands in /var/tmp/build/go1.4/bin
patching file cmd/go/internal/work/action.go
patching file cmd/link/internal/ld/lib.go
Hunk #1 succeeded at 445 (offset -8 lines).
Building Go cmd/dist using /var/tmp/build/go1.4.
go tool dist: cannot invoke C compiler "/var/tmp/dist/android-toolchain/android-ndk/x86_64/bin/clang": exit status 127

Go needs a system C compiler for use with cgo.
To set a C compiler, set CC=the-compiler.
To disable cgo, set CGO_ENABLED=0.

Command output:

/var/tmp/dist/android-toolchain/android-ndk/x86_64/bin/clang60: error while loading shared libraries: libtinfo.so.5: cannot open shared object file: No such file or directory

Looking at the commits from that day, the most likely cause seems to be #31130.

Child Tickets

Change History (1)

comment:1 Changed 10 months ago by boklm

Resolution: fixed
Status: newclosed

I confirmed the error is caused by #31130 as reverting the patch solves the build issue.

So I reverted the patch on master with 2d7921cd17c52fe2a16d0a3dc19235d0d48fa575 and reopened #31130.

Note: See TracTickets for help on using tickets.