Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#3278 closed defect (not a bug)

Tor, Skype and MAIN BUG

Reported by: tractor Owned by:
Priority: High Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.2.27-beta
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi,
Im using windows 7, skype 5.3.0.111, Tor 0.2.2.27-beta.
Every time when im creating relay and skype is opened im getting bug. Skype is blocking my port, but its not worst tingh when im bulding my relay, see below:

Bulding relay with opened Skype:

may 24 16:16:20.193 [Notice] Tor v0.2.2.27-beta
(git-e3b8457eb38ee76a). This is experimental software. Do not rely on it for strong anonymity. (Running on Windows 7 Service Pack 1 [workstation])
may 24 16:16:20.193 [Notice] Initialized libevent version 2.0.11-stable using method win32. Good.
may 24 16:16:20.193 [Notice] Opening OR listener on 0.0.0.0:443
may 24 16:16:20.193 [Warning] Could not bind to 0.0.0.0:443: Address already in use [WSAEADDRINUSE ]. Is Tor already running?
may 24 16:16:20.193 [Warning] Failed to parse/validate config: Failed to bind one of the listener ports.
may 24 16:16:20.193 [Error] Reading config failed--see warnings above.

Ok now im closing skype and once again im bulding relay:

may 24 16:19:55.058 [Notice] Tor v0.2.2.27-beta (git-e3b8457eb38ee76a). This is experimental software. Do not rely on it for strong anonymity. (Running on Windows 7 Service Pack 1 [workstation])
may 24 16:19:55.058 [Notice] Initialized libevent version 2.0.11-stable using method win32. Good.
may 24 16:19:55.058 [Notice] Opening OR listener on 0.0.0.0:443
may 24 16:19:55.167 [Notice] Opening Directory listener on 0.0.0.0:9030
may 24 16:19:55.167 [Notice] Opening Socks listener on 127.0.0.1:9050
may 24 16:19:55.167 [Notice] Opening Control listener on 127.0.0.1:9051
may 24 16:19:55.386 [Notice] Parsing GEOIP file C:\XXXX\YYYY\AppData\Roaming\tor\geoip.
may 24 16:19:57.804 [Notice] OpenSSL OpenSSL 1.0.0d 8 Feb 2011 looks like version 0.9.8m or later; I will try SSL_OP to enable renegotiation
may 24 16:19:57.804 [Notice] Your Tor server's identity key fingerprint is 'whatnext 973591D6DB491A8ED2AE05CA34656B23244B1F24'
may 24 16:19:57.804 [Notice] We now have enough directory information to build circuits.
may 24 16:19:57.804 [Notice] Bootstrapped 80%: Connecting to the Tor network.
may 24 16:19:57.804 [Notice] New control connection opened.
may 24 16:19:57.804 [Notice] New control connection opened.
may 24 16:19:57.804 [Notice] New control connection opened.
may 24 16:19:57.804 [Notice] Guessed our IP address as ZZ.XXX.YYY.V (source: XXX.ZZZ.CCC.VVV).
may 24 16:19:59.660 [Notice] Bootstrapped 85%: Finishing handshake with first hop.
may 24 16:19:59.879 [Notice] Bootstrapped 90%: Establishing a Tor circuit.
may 24 16:20:01.189 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
may 24 16:20:01.189 [Notice] Bootstrapped 100%: Done.
may 24 16:20:01.189 [Notice] Now checking whether ORPort zz.xxx.ccc.v:443 and DirPort ZZ.XXX.CCC.V:9030 are reachable... (this may take up to 20 minutes -- look for log messages indicating success)

OK im thinking GREAT, skype block my port but now when im close it, it's working fine... NO!

After 20 minutes im getting:

may 24 16:39:58.510 [Warning] Your server (zz.xxx.ccc.v:443) has not managed to confirm that its ORPort is reachable. Please check your firewalls, ports, address, /etc/hosts file, etc.
may 24 16:39:58.510 [Warning] Your server (zz.xxx.ccc.v:9030) has not managed to confirm that its DirPort is reachable. Please check your firewalls, ports, address, /etc/hosts file, etc.

Im using aleays newest tor version, but i have this bug in every tor version

I think that we got two bugs. First one is skype is blocking port on windows 7, and tor cannot built relay, and second, when im building relay i missing my certificate or somthing.

Child Tickets

Change History (4)

comment:1 Changed 8 years ago by tractor

Tor Status:
[16:19:57] The Tor Software is Running - You are currently running version "0.2.2.27-beta (git-e3b8457eb38ee76a)" of the Tor software.
[16:39:58] Server Port Reachability Test Failed - Your relay's server port is not reachable by other Tor clients. This can happen if you are behind a router or firewall that requires you to set up port forwarding. If zz.xxx.yyy.s:443 is not your correct IP address and server port, please check your relay's configuration.
[16:39:58] Directory Port Reachability Test Failed - Your relay's directory port is not reachable by other Tor clients. This can happen if you are behind a router or firewall that requires you to set up port forwarding. If zz.xxx.ccc.v:9030 is not your correct IP address and directory port, please check your relay's configuration.

I'm not using firewall, and port forwarding in my router is working fine.
Windows 7 64 bit
Router tp-link tl-wr340g

comment:2 Changed 8 years ago by nickm

Resolution: not a bug
Status: newclosed

Sorry for the delay! This is a bugtracker, not a support site, so support requests tend to get handled too slowly. We've instituted a real support process to try to make this go faster in the future.

So, the "orport auto" feature in 0.2.2.x should fix the skype issue. Or even easier; picking another port besides 443 should work ok too.

The second issue looks like your router isn't in fact reachable from the outside for some reason; it doesn't look a Tor bug currently. You can get more help at one of the venues listed at https://www.torproject.org/docs/faq.html.en#SupportMail . (Here's hoping you already tried one; I'd hate to think you were waiting on this ticket. :/ )

comment:3 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:4 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.