Opened 7 weeks ago

Last modified 5 weeks ago

#32923 reopened enhancement

Detached Tor Browser Firedox APK - Option to Customize Configuration - VPN Function - Android

Reported by: onestep Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version: Tor: 0.4.2.5
Severity: Major Keywords: Tor Browser APK Android VPN Nodes
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I can't say better than what is said here:
https://www.reddit.com/r/TOR/comments/af9brd/separate_apk_for_torbrowser_alpha_detached_from/

https://blog.torproject.org/comment/282067#comment-282067
https://trac.torproject.org/projects/tor/ticket/28786

How are you guys paying zero attention to this critical function?
Taking away user customization cripples the fundamental principles of freedom to choose and speak freely.

Also, as Android' built in Always-on VPN can take advantage of outdated Orbot's VPN feature to tunnel everything over Tor with zero leak when user chooses Block internet without VPN option in Android network settings.

Just need a separate Tor Browser APK that can be used with good old Orbot. Or a new form of something similar that can allow users to choose.

I recently faced a major headache with Facebook's onion address. Whereby it won't allow users to upload anything. Only solution was to choose a customized IP/Node a user had used to access Facebook before. And above feature can help evade such lock downs.

I sincerely hope someone takes this seriously and does something.

Very similar report was filed 13 months before!!!

Child Tickets

Change History (6)

comment:1 Changed 7 weeks ago by sysrqb

Resolution: duplicate
Status: newclosed

We'll get to this eventually, but it is not a high priority feature. In the near future, we will (basically) completely re-write Tor Browser for Android, and this will be a feature we add. However, removing tor from the app excludes an essential component of Tor Browser. In that case, the app is not Tor Browser anymore. Do not expect Tor Browser will provide a UI for tweaking all of tor's configuration options, either. If a website is broken, then the website should be fixed - including Facebook's.

comment:2 Changed 6 weeks ago by arma

(#28786 is what this ticket is a duplicate of.)

comment:3 Changed 6 weeks ago by onestep

It has been over a year now! What do you mean by near future? And what feature you are planning to add?

comment:4 Changed 6 weeks ago by onestep

Resolution: duplicate
Status: closedreopened

Do you really think Facebook's gonna give a shit? It's up to us now. You should have at least provided a way to use a detached Tor Browser to work with Orbot for now until there's something new on the horizon to use.

comment:5 in reply to:  description Changed 5 weeks ago by cypherpunks

Replying to onestep:

Also, as Android' built in Always-on VPN can take advantage of outdated Orbot's VPN feature to tunnel everything over Tor with zero leak when user chooses Block internet without VPN option in Android network settings.

This is simply and sadly not true! Don't rely on this feature. It is leaky by design! Don't trust this block anything but or orbot feature please!

This Android feature natively is multi user supported. This means you can run a 2nd profile (user) or Android guest account or Android work profile under same user without switching and have actively bypass the Android' built in Always-on VPN (block everything else's) option.

In fact you can even configure two or more Android always online VPN in coexistence parallel. For this profiles each.

And tunneling and blocking some system process seems broken too. Ntp for example. Feel free to check with Wireshark on your own.

This is the reason I badly missing transparent proxy with root support removed from orbot earlier. :(

...

comment:6 in reply to:  description Changed 5 weeks ago by cypherpunks

Replying to onestep:

Just need a separate Tor Browser APK that can be used with good old Orbot. Or a new form of something similar that can allow users to choose.

There is a workaround. Using orbot directly with tbb without leaks. You can reconfigure tbb to use not it's own built-in Tor Socksport but orbots.

Go-to

about:config

And change socks 5 Port to default 9050. Traffic will now flow through orbot. And tbb can work fine in coexistence.

Simply ignore the bundled Tor of tbb!

Note: See TracTickets for help on using tickets.