Opened 5 months ago

Last modified 5 months ago

#32946 new defect

Something in the jenkins setup is reverting the website to an older version

Reported by: ggus Owned by: hiro
Priority: Medium Milestone:
Component: Webpages/Website Version:
Severity: Normal Keywords:
Cc: traumschule, trac-dip-importer, ggus Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Someone on IRC pinged us to report that the links to download Tor Browser from https://www.torproject.org/download/languages/ and https://www.torproject.org/download/ have the wrong version in all platforms and languages.

Website is serving: 9.0.2

Latest stable: 9.0.4.

Child Tickets

Change History (4)

comment:1 Changed 5 months ago by boklm

The git repository has the correct version, and the website had the correct version previously, so it seems to be an issue somewhere with the jenkins setup reverting to an old version of the website.

comment:2 Changed 5 months ago by boklm

There was the same issue a few days ago, which was fixed after pushing an empty commit.

comment:3 Changed 5 months ago by boklm

Summary: Download page is serving outdated TBB versionSomething in the jenkins setup is reverting the website to an older version

comment:4 Changed 5 months ago by weasel

The actual problem is that both thelektor-website-tpo-translation adn the lektor-website-tpo-translation-any job get triggered, and that the -any job built against an old version of master.

It should now explicitly check out a current version of master, as of 4697b76c668f5ae1b2e24a4a0313770ed1f10968 in jenkins/tools.
However, the real fix is that -any should not get triggered on updates to master.

Note: See TracTickets for help on using tickets.