Opened 7 months ago

Closed 7 months ago

#32983 closed defect (duplicate)

browser.sessionhistory.max_entries has no effect

Reported by: pf.team Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords: tbb-linkability, tbb-9.0-issues
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Prior to version 9.* users could change browser.sessionhistory.max_entries to restrict history length for every separate browser tab, by setting a value lower than the default 50.
This allowed, on one hand, to prevent additional data being collected about the user - namely, how many pages they visited in this particular tab - and on the other, somewhat cut down on memory consumption.

Tor Browser version 9 and higher ignore all browser.sessionhistory.max_entries values below 50.

Child Tickets

Change History (3)

comment:1 Changed 7 months ago by Thorin

@gk ... duplicate of #8213 ?

@pf.team - see https://trac.torproject.org/projects/tor/ticket/8213#comment:5 : this has been broken since Firefox 61 .. and, IMO, this is not a FPing vector (history per tab will always be between 1 and 50: it's not a stable or meaningful metric) nor can the History API leak anything about the tab's history

comment:2 Changed 7 months ago by Thorin

Keywords: tbb-linkability added; tabs history tbb-usability tbb-fingerprinting removed

comment:3 Changed 7 months ago by gk

Resolution: duplicate
Status: newclosed

Thanks, Thorin. Agreed.

Note: See TracTickets for help on using tickets.