Opened 9 months ago

Closed 8 months ago

Last modified 8 months ago

#32992 closed defect (fixed)

TBB Project for LZMA

Reported by: sisbell Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-mobile, tbb-rbm, TorBrowserTeam202003R
Cc: sysrqb, sisbell, tbb-team Actual Points: 1
Parent ID: #28704 Points:
Reviewer: Sponsor:

Description (last modified by sisbell)

Create a tbb project to build source code targeting the android platform.

Source code: https://git.tukaani.org/xz.git

Child Tickets

Change History (19)

comment:1 Changed 9 months ago by boklm

What do you mean by "Android Project for LZMA"?

comment:2 in reply to:  1 Changed 9 months ago by cypherpunks

Replying to boklm:

What do you mean by "Android Project for LZMA"?

From now on tbb Android and orbot can built with this library flag set in configure.

--with-lzma

Effectively reducing directory bandwidth by fetching better compressed descriptors

comment:3 Changed 9 months ago by sisbell

Description: modified (diff)

comment:4 Changed 9 months ago by pili

Keywords: TorBrowserTeam202002 added; TorBrowserTeam202001 removed

Moving tickets to February

comment:5 Changed 9 months ago by sisbell

Summary: Android Project for LZMATBB Project for LZMA

comment:6 Changed 8 months ago by sysrqb

Status: newneeds_revision

Similar to #32991, are there signed git tags available for this?

comment:7 Changed 8 months ago by sisbell

As far as I can tell, it does have a signed tag but I'm unable to verify it with rbm build

From git project for xz

$ git tag -v v5.2.4
object b5be61cc06088bb07f488f9baf7d447ff47b37c1
type commit
tag v5.2.4
tagger Lasse Collin <lasse.collin@tukaani.org> 1525017879 +0300

XZ Utils 5.2.4
gpg: Signature made Sun 29 Apr 2018 09:04:44 AM PDT
gpg:                using RSA key 3690C240CE51B4670D30AD1C38EE757D69184620
gpg:                issuer "lasse.collin@tukaani.org"
gpg: Good signature from "Lasse Collin <lasse.collin@tukaani.org>" [unknown]
gpg: WARNING: This key is not certified with a trusted signature!
gpg:          There is no indication that the signature belongs to the owner.
Primary key fingerprint: 3690 C240 CE51 B467 0D30  AD1C 38EE 757D 6918 4620

I add the following to xz/config

version: 5.2.4
git_url: https://git.tukaani.org/xz.git
git_hash: 'v[% c("version") %]'
tag_gpg_id: 1
gpg_keyring: xz.gpg
filename: '[% project %]-[% c("version") %]-[% c("var/osname") %]-[% c("var/build_id") %].tar.gz'

The xz.gpg file has the key

./xz.gpg
--------
pub   rsa4096 2010-10-24 [SC] [expires: 2020-12-22]
      3690C240CE51B4670D30AD1C38EE757D69184620
uid           [ unknown] Lasse Collin <lasse.collin@tukaani.org>
sub   rsa4096 2010-10-24 [E] [expires: 2020-12-22]

And then building the project, I get an error

Error: v5.2.4 is not a signed tag

Any ideas on what is going wrong?

comment:8 Changed 8 months ago by gk

Keywords: tbb-parity removed

No parity involved here, we don't have this on desktop yet, see: #22341. For what it's worth ahf over in #22341 suggested back then to start with zstd and see how that goes.

comment:9 Changed 8 months ago by sisbell

No Changes, just broke apart into its own branch

https://github.com/sisbell/tor-browser-build/commits/bug-32992

comment:10 in reply to:  7 ; Changed 8 months ago by boklm

Replying to sisbell:

And then building the project, I get an error

Error: v5.2.4 is not a signed tag

Any ideas on what is going wrong?

I have no idea what's going wrong. Do you have a branch with the changes you tried so I can investigate the issue?

comment:11 Changed 8 months ago by eighthave

Cc: hans@… removed

comment:12 in reply to:  10 ; Changed 8 months ago by sisbell

Replying to boklm:

Replying to sisbell:

And then building the project, I get an error

Error: v5.2.4 is not a signed tag

Any ideas on what is going wrong?

I have no idea what's going wrong. Do you have a branch with the changes you tried so I can investigate the issue?

I created a branch with the key and config that I was using when I encountered the errors. I'll do some more testing as well on this

https://github.com/sisbell/tor-browser-build/commits/bug-32992a

comment:13 in reply to:  12 ; Changed 8 months ago by boklm

Replying to sisbell:

Replying to boklm:

Replying to sisbell:

And then building the project, I get an error

Error: v5.2.4 is not a signed tag

Any ideas on what is going wrong?

I have no idea what's going wrong. Do you have a branch with the changes you tried so I can investigate the issue?

I created a branch with the key and config that I was using when I encountered the errors. I'll do some more testing as well on this

https://github.com/sisbell/tor-browser-build/commits/bug-32992a

So it seems the issue is that keyring/xz.gpg does not contain any key. This command outputs nothing:

$ gpg --no-default-keyring --keyring keyring/xz.gpg --list-keys

And the size of the file is only 32 bytes.

comment:14 in reply to:  13 Changed 8 months ago by sisbell

Replying to boklm:

Replying to sisbell:

Replying to boklm:

Replying to sisbell:

And then building the project, I get an error

Error: v5.2.4 is not a signed tag

Any ideas on what is going wrong?

I have no idea what's going wrong. Do you have a branch with the changes you tried so I can investigate the issue?

I created a branch with the key and config that I was using when I encountered the errors. I'll do some more testing as well on this

https://github.com/sisbell/tor-browser-build/commits/bug-32992a

So it seems the issue is that keyring/xz.gpg does not contain any key. This command outputs nothing:

$ gpg --no-default-keyring --keyring keyring/xz.gpg --list-keys

And the size of the file is only 32 bytes.

On my system, I'm seeing

-rw-r--r--   1 shane shane 6513 Mar  1 19:01 xz.gpg

and

$ gpg --no-default-keyring --keyring ./xz.gpg --list-keys
./xz.gpg
--------
pub   rsa4096 2010-10-24 [SC] [expires: 2020-12-22]
      3690C240CE51B4670D30AD1C38EE757D69184620
uid           [ unknown] Lasse Collin <lasse.collin@tukaani.org>
sub   rsa4096 2010-10-24 [E] [expires: 2020-12-22]

comment:15 Changed 8 months ago by sisbell

I see my mistake. I have the keyring in wrong location.

comment:16 Changed 8 months ago by sisbell

Moved the gpg key to keyring directory

Added the configure_opt_project variable that uses common CC and host fields.

https://github.com/sisbell/tor-browser-build/commits/bug-32992b

comment:17 Changed 8 months ago by sisbell

Keywords: TorBrowserTeam202003R added; TorBrowserTeam202002 removed
Status: needs_revisionneeds_review

comment:18 in reply to:  16 Changed 8 months ago by boklm

Resolution: fixed
Status: needs_reviewclosed

Replying to sisbell:

Moved the gpg key to keyring directory

Added the configure_opt_project variable that uses common CC and host fields.

https://github.com/sisbell/tor-browser-build/commits/bug-32992b

This looks good to me. I cherry-picked the patch to master as commit bd21fef218312e8c64e932de989a848e98e2027a.

comment:19 Changed 8 months ago by sisbell

Actual Points: 1
Note: See TracTickets for help on using tickets.