Opened 2 months ago

Last modified 8 weeks ago

#33003 needs_information defect

Tor browser / Firefox telemetry data

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: TorBrowserTeamTriaged
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

https://seclists.org/fulldisclosure/2019/May/17

It seems this issue is still not fixed although it has been announced in May 2019. URLs containing "mozilla", "google" etc. (as described) can still be found in about:config

This is well known in Firefox and there are various user.js projects which eliminate background connections.

Although in the case of Tor Browser the IP address is anonymized this is still unacceptable, especially for a browser which claims to be focused on protecting privacy.

As a privacy focused user: I expect 0 (zero) background connections and no possibility to enable such (through preferences or through about:config).

Child Tickets

Change History (6)

comment:1 Changed 2 months ago by nickm

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team

comment:2 Changed 2 months ago by sysrqb

Status: newneeds_information

I don't understand the bug. Tor Browser has some preferences with URLs as their value and some of them contain "mozilla" or "google" or "org" (?). Their existence is not a bug, if they are used in unexpected ways, then that may be a bug. This happens occasionally, but are you reporting this is happening now? Can you provide steps for reproducing it?

comment:3 Changed 2 months ago by sysrqb

Keywords: TorBrowserTeamTriaged added
Priority: HighMedium
Severity: MajorNormal

comment:4 Changed 2 months ago by cypherpunks

Their existence is not a bug

Still that same existence is an open door to anti-privacy. Suppose a case when the user plays with about:config or other preferences and inadvertently enables an anti-privacy feature such as telemetry or anything else which exists in Firefox. If the URLs had been removed he would not be able to de-anonymize the browser. IOW not having those URLs can be seen as a precaution.

if they are used in unexpected ways, then that may be a bug.

As I mentioned initially, my personal expectation from a privacy respecting browser is 0 (zero) background connections, i.e. ones not initiated by me explicitly or through a setting which I explicitly set-up. This means: out of the box there should be no connections other than those related to typed URLs. I suppose HTTPS-E must be considered along these lines too as it has some mechanism for remote updates. All that should be an opt-in on first run.

This happens occasionally, but are you reporting this is happening now?

I don't know how to tcpdump the connections which Tor Browser makes as I don't know how to tcpdump anything that passes through Tor. If you explain how to do this I can try.

Can you provide steps for reproducing it?

I found this which seem related to all those background connections (in Firefox):

https://bugzilla.mozilla.org/show_bug.cgi?id=1432248

Note how Mozilla (that "privacy respecting" and "non-profit" organization) closed this as WONTFIX and linked it to another bug report which was also closed as WONTFIX. To date these automatic connections in Firefox persist and their documentation about how to disable them is still not complete. Mozilla Firefox's privacy policy is an anti-privacy policy. Just read:

https://www.mozilla.org/en-US/privacy/firefox/

By default they *share* a lot. But private means not shared, i.e. the opposite.

In contrast ungoogled-chromium makes zero background connections out of the box (tested). Perhaps it is a better alternative for being a new basis for Tor Browser because it can already be configured to work through Tor proxy, so all it needs is some fine tuning about reducing the fingerprint. What do you say? (I realize this is not a bug report but a wider discussion. Please advise where it is appropriate to talk about that if you think it is worthwhile)

comment:5 Changed 8 weeks ago by cypherpunks

https://it.slashdot.org/story/20/02/03/2012236/firefox-now-shows-what-telemetry-data-its-collecting-about-you

I am pretty sure this is all anti-GDPR.

The Tor team should definitely consider switching to ungoogled-chromium.

comment:6 Changed 8 weeks ago by cypherpunks

Yeah ungoogled-chromium is faster than fatfox. Devs should try it out.

Note: See TracTickets for help on using tickets.